LPCXpresso55s69 update to OpenSDA

Showing results for 
Search instead for 
Did you mean: 

LPCXpresso55s69 update to OpenSDA

Contributor II

The first step to update the jtag chip firmware on an Xpresso board is to convince the debug it is a USB drive.

I have tried holding the reset button while plugging in the debug port and have not gotten the debug drive to appear on my Windows 10 machine.  I also tried all the other buttons on the board.

Does anyone know how to get the LPCXpresso55s69 debugger to appear as a USB Drive?  Is this the wrong proceedure for this devkit?

0 Kudos
2 Replies

Contributor II

Here is the process I discovered to update the JTag firmware to LPC-Link2:

Updating the LPCXpresso55S69 Board

Unlike previous boards from NXP this one requires using their update utility.

Get the required programs and files

Firmware_JLink_LPCXpressoV2_20190404.bin from Segger https://www.segger.com/downloads/jlink/#LPC-Link2

LPCScript from NXP https://www.nxp.com/design/microcontrollers-developer-resources/lpc-microcontroller-utilities/lpcscr...

Install LPCScript

Install Jumper J4 on the board, forcing a the Debug processor to DFU Boot

Attach the board with a USB cable between the computer and debug port.

Launch the command line LPCScript

Test with command C:\NXP\LPCScrypt_2.1.0_842\bin>lpcscrypt querypart

Should respond with

partID = 0xa00bcb3c 80

decode = LPC4322: BankA 512KB

Core Clock = 180000000


Copy the downloaded Segger .bin file into the NXP bin directory

Enter the command C:\NXP\LPCScrypt_2.1.0_842\bin>lpcscrypt program Firmware_JLink_LPCXpressoV2_20190404.bin BankA 

Should get response


Programmed 65476 bytes to 0x1a000000 in 1.026s (62.325KB/sec)


I have attached a pdf of this process to this post

0 Kudos

NXP TechSupport
NXP TechSupport

Thanks George for the contribution, but there is a simpler way to update the firmware on the debug probe of an LPCXpresso55S69/S28/S16/S06, which is of the LPC-Link2 type, that I wanted to share with our users. (Note that LPC55S36 EVK has an MCU-Link, so refer to that board's user guide if that's what you are using; process is similar but with a different installer). Also note that we dont use OpenSDA firmware on these probe types

The steps about entering DFU mode are correct - install the DFU jumper and power cycle.

Before attaching the board to the PC, install LPCScrypt then run either of these two scripts/utilities that come with the LPCScrypt installation (if using Windows, press the Windows key and start typing the utility name to find them, otherwise look at the scripts directory of the LPCScrypt installation):

- Program LPC-Link2 with CMSIS DAP for the default NXP firmware, or
- Program LPC-Link2 with Segger J-Link if you want that firmware.

You can also refer to the getting started guide of the board you are using, which would cover this. The user guide also covers this.

0 Kudos