How to repair MCUXpresso Config Tools?

cancel
Showing results for 
Search instead for 
Did you mean: 

How to repair MCUXpresso Config Tools?

428 Views
mitterha
Senior Contributor I

Hello,

I installed the new v7.0.1 parallel to v7.0 today (different folder).

I opened an existing MEX file by doulbe clicking and everything worked fine. The MEX file is for a XIP project in IAR.

After changing the configuration in IAR (from XIP-debug to SDRAM-debug) and running it on the development board I switched back to MCUXpresso Config Tools to change clock settings (the tool was open the whole time) and after clicking the "Update Code" button it showed that the DCD files are not included in the project anymore (which is true because of the change to SDRAM debug) and it is going to delete the DCD files. I removed the checkbox next to the DCD files because I wanted to keep them for later changing back to XIP-debug and clicked update.

The tool still deleted the DCD files. Now it often hangs for quite a long time after clicking Update Code before it opens the change-window where it only shows "?" for a lot of fields.

Closing the file and opening the tool again helped but the error came again later.

I attached the error log (from today, without paths) and the MEX file to this post.

Do I have to change anything to fix this issue?

Kind regards,

Stefan

UPDATE:

It just happened again. The window looks like the following:

pastedImage_1.png

The newest error log entry is

!ENTRY org.eclipse.core.jobs 4 2 2020-03-06 11:17:40.073
!MESSAGE An internal error occurred during: "Updating status of the generated files".
!STACK 0
java.lang.IllegalArgumentException: 'other' is different type of Path
    at sun.nio.fs.WindowsPath.relativize(WindowsPath.java:388)
    at sun.nio.fs.WindowsPath.relativize(WindowsPath.java:44)
    at com.nxp.swtools.sdkproject.ToolchainProjectDestinationPathProvider.getDestinationPath(ToolchainProjectDestinationPathProvider.java:39)
    at com.nxp.swtools.sdkproject.ToolchainProjectDestinationPathProvider.getDestPathProjectRelative(ToolchainProjectDestinationPathProvider.java:56)
    at com.nxp.swtools.sdkproject.internal.GeneratedFilesStatusProvider.getProjectFileStatus(GeneratedFilesStatusProvider.java:480)
    at com.nxp.swtools.sdkproject.internal.GeneratedFilesStatusProvider$GeneratedFileStatusDelayedRefresh.lambda$0(GeneratedFilesStatusProvider.java:412)
    at java.util.ArrayList.forEach(ArrayList.java:1257)
    at com.nxp.swtools.sdkproject.internal.GeneratedFilesStatusProvider$GeneratedFileStatusDelayedRefresh.refreshTool(GeneratedFilesStatusProvider.java:410)
    at com.nxp.swtools.sdkproject.internal.GeneratedFilesStatusProvider$GeneratedFileStatusDelayedRefresh.runAction(GeneratedFilesStatusProvider.java:391)
    at com.nxp.swtools.common.utils.runtime.DelayedExecution$1.run(DelayedExecution.java:375)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63)

6 Replies

176 Views
b23204
NXP Employee
NXP Employee

Stefan,

we have tried on two different machines to open MEX file from the zip file you provided (flexspi_nor_polling_transfer2.zip) using MCU Config Tools 7.0.1 and we do not see any problem in Update Code:
pastedImage_1.png

Can you please double check the ZIP content and let us know absolute path, the ZIP should be extracted?

Can you check the access rights to the specified folder?

Patches you mention should not affect Update Code, because Peripherals tool is disabled in your MEX configuration.

Kinds regards

Marek

Regards,
Marek
0 Kudos

176 Views
mitterha
Senior Contributor I

Hello Marek,

I downloaded the ZIP-file and unpacked it several times. The error only happened once again and I got a screenshot of the error window

pastedImage_1.png

The absolute path was C:\Users\firstname.lastname\Desktop\MCUXpressoTest\flexspi_nor_polling_transfer2

I have full access rights to the folder.

After the one error message it is not happening again at the moment so I can't recreate it. I will mark this post as probably answered for now and in case the error happens again I will open a new question with instructions on how I produced the error.

Thank you for you help,

Stefan

0 Kudos

176 Views
liborukropec
NXP Employee
NXP Employee

Hello Stefan,

I reproduced similar behavior (even not with the ??? in the update dialog) when I removed the read access (on filesystem level) to the IAR project file (*.ewp) - then the tool was not able to read the file and the DCD files were offered to delete (the fact you unchecked and they were deleted is a bug, no doubt).

So my recommendation is to close IAR when you go to Config Tools to edit the configuration - at least when the problem is reproduced again. It is possible that the files are locked exclusively to IAR.

Regards,

Libor

176 Views
mitterha
Senior Contributor I

Thank you Libor, I will do that!

Kind regards,

Stefan

0 Kudos

176 Views
b23204
NXP Employee
NXP Employee

Hi Stefan,

thank you for reporting this problem. I tried to reproduce your issue today, but it seems I'm not able to reproduce it. If you have some more details, how to reproduce (what actions to do in IAR EW), or you can share you whole project directory (we'd need complete project directory structure, all project files and empty source files, we do not need content of your source files, just file names and their location in the project directory structure), it will be helpful.

Please ensure you have in the project folder only one EWP file and one EWW file, so only one IAR project is assigned to the MEX file. Some older IAR versions created duplicated files.

About file deletion: the tool should offer to delete the source file during project update in case the file was generated previously and currently it is no more generated. There is problem the file is deleted even the check-box is unchecked, and I have created request to fix this problem for next version of the tool. As a workaround, you can delete previously generated files in the MEX file, see section <generated_project_files> - e.g. remove all files from the section and keep the section empty. Then reload the MEX file in Config Tools. Example of the section in the MEX file (bold part should be removed):

      <dcdx name="DCDx" version="2.0" enabled="true" update_project_code="true">
         <generated_project_files>
            <file path="xip/evkmimxrt1020_sdram_ini_dcd.c" update_enabled="true"/>
            <file path="xip/evkmimxrt1020_sdram_ini_dcd.h" update_enabled="true"/>
         </generated_project_files>

Sorry for inconvenience

Regards

Marek

Regards,
Marek
0 Kudos

176 Views
mitterha
Senior Contributor I

Hello Marek,

thank you for your answer.

I just recreated the problem with a new demo project so I think my project is not needed here.

I installed MCUXpresso Config Tools v7.0.1 next to other MCUXpresso Config Tools versions

pastedImage_1.png

I did the following  steps on RT1020:

  1. Open Config Tools (it opened  Version and Build id 7.0.0.202002070841) and clone the driver example project flexspi_nor_polling_transfer for IAR EWARM.
  2. Update the project files with MCUXpresso Config Tools
  3. Close MCUXpresso Config Tools
  4. Open EWARM project and Download&Debug the example (I left default debug configuration)
  5. Stop Debugging
  6. Open the MEX File with MCUXpresso Config Tools by double clicking it
  7. I think there was a short error dialog window open and the "Update Code" button was green - but too short to read the dialog and it automatically closed the error dialog.
  8. Click Update Code - there are a lot of question marks again. If I hover above the question marks most of them show an empty box and the dcd question marks show the hint "Warning: The source file not found in the toolchain project and will not be compiled until you add it.

If I go to Help>About>Details the MIMXRT10.... data and some of the components get listed as version 7.0.1 could that be a problem? Additionally I have installed ADC_ETC, ADC and eDMA component hotfixes in the last weeks.

Is the EDMA Auto stop request initialization missing? 

Are there bugs in ADC_ETC and ADC driver? 

I have attached the demo project to this post. If I just open the MEX file with a doulbe click there is a short error message (automatically closed) and the "Update Code" function does not work properly.

Kind regards,

Stefan

0 Kudos