Bug: Unknowns symbols are generated with SLOW_IRCLK trimming

cancel
Showing results for 
Search instead for 
Did you mean: 

Bug: Unknowns symbols are generated with SLOW_IRCLK trimming

139 Views
NXP Employee
NXP Employee

Hi,

I have an application with MKV11 and I am using slow IRCLK trimming to get up to 75MHz with core clock. Everything works nicely, except that the final generated file (but not the preview) always contains some weird symbols (see screenshot below). It's not a critical issue as all that needs to be done is replacement of symbols with spaces, but I thought you should know about this. :smileyhappy:  I should be using the latest config tool version.

Best regards

pastedImage_1.png

Labels (1)
Tags (1)
0 Kudos
2 Replies

19 Views
NXP Employee
NXP Employee

Hi Zbynek and Omar.

thank you for reporting this problem. It will be fixed in next MCUXpresso Config Tools update. Meanwhile, you can use attached patch to fix the issue for KV10 and KV11 processors.

How to install the patch:

MCUXpresso Config Tools v7: Go to File > Data Manager > Import, select the attached archive and choose processors you want to update

MCUXpresso IDE 11.1.x: Go to Config Tools > Data Manager > Import, select the attached archive and choose processors you want to update

After installing the patch please restart the tool.

Regards,

Lukas

19 Views
NXP TechSupport
NXP TechSupport

Hello Zbynek Mynar 

 

I replicate the configuration on my side and found the same error of bad character sequence.

pastedImage_2.png

I followed the same workaround and deleted the spaces, after that the project  compiled with no errors.

pastedImage_3.png

lpcxpresso_support I think this is a small issue to have in count in further releases.

Thanks

 

Best regards,

Omar

0 Kudos