ls2088A hang after 'reboot'

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

ls2088A hang after 'reboot'

1,635 Views
jiafang
Contributor I

Use LSDK 17-12 version kernel to bootup ls2088ardb reference board.

Login after about 3mins~5mins, and then 'reboot', the board can not boot up again.

Part log is:

[...

e1000e: EEE TX LPI TIMER: 00000000
reboot: Restarting system
Re

]

The board stops at here.

If login after 15mins or 20mins, the board can boot up well.

Is there anyone has the same issue ?

Labels (1)
0 Kudos
6 Replies

1,299 Views
jiafang
Contributor I

Hi Yiping Wang

It seems like I have deleted your reply after I edited to add the attached file(bootlog) ,sorry, I didn't mean it.

It is easy to reproduce, you can try it as well.

I'm not sure it is related to NFS bootway.

Thanks,

Fang

0 Kudos

1,299 Views
yipingwang
NXP TechSupport
NXP TechSupport

Hello jia fang,

The issue QUBOOT-3723 has already been fixed in the patch [U-Boot] driver: fsl-mc: Perform fsl-mc fdt fixup for lazyapply dpl - Patchwork .

It seems that the reboot problem is related with E1000 Timer, are you using NFS rootfs now?

Would you please provide the whole console log including u-boot, Linux Kernel booting up and the execution of reboot command?


Have a great day,
TIC

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

1,299 Views
jiafang
Contributor I

It is easy to reproduce with the NFS boot way. You can have a try.

But I'm not sure if without NFS boot, it can be reproduced as well.

Please see the attachment.

0 Kudos

1,299 Views
jiafang
Contributor I

Oh, I use the flash vbank4  and the lsdk1712 version and find that the issue is still there.

U-Boot 2017.07-g9f7df1b (Dec 23 2017 - 00:31:21 +0800)

SoC: LS2088AE Rev1.1 (0x87090011)
Clock Configuration:
CPU0(A72):1800 MHz CPU1(A72):1800 MHz CPU2(A72):1800 MHz
CPU3(A72):1800 MHz CPU4(A72):1800 MHz CPU5(A72):1800 MHz
CPU6(A72):1800 MHz CPU7(A72):1800 MHz
Bus: 700 MHz DDR: 1866.667 MT/s DP-DDR: 1600 MT/s
Reset Configuration Word (RCW):
00000000: 483038b8 48480048 00000000 00000000
00000010: 00000000 00000000 00a00000 00000000
00000020: 01001180 00002581 00000000 00000000
00000030: 00400c0b 00000000 00000000 00000000
00000040: 00000000 00000000 00000000 00000000
00000050: 00000000 00000000 00000000 00000000
00000060: 00000000 00000000 00027000 00000000
00000070: 412a0000 00040000
Model: Freescale Layerscape 2080a RDB Board
Board: LS2088AE Rev1.1-RDB, Board Arch: V1, Board version: F, boot from vBank: 4
FPGA: v1.22

0 Kudos

1,299 Views
jiafang
Contributor I

I tried to update the firmware to LSDK1712 version. then I found the mc bus does not probed.

There should be some problem in MC10.4.0.

The issue is same as the LSDK1712 open issue QUBOOT-3723. So I change to use the 'fsl_mc apply dpl' not the 'lazyapply', the MC works well now.

And it seems like the 'reboot' issue disappear now.

0 Kudos

1,299 Views
jiafang
Contributor I

There is some commits related 'firmware: psci", is it possible there is some issue in PSCI ?

0 Kudos