VPP building problem in the LSDK 20.12

cancel
Showing results for 
Search instead for 
Did you mean: 

VPP building problem in the LSDK 20.12

179 Views
ELLIOTT
Contributor III

Hi All,

 

I just compiled a VPP app according to LSDKUG_Rev20.12.pdf,page:1212-1213.

as follow,but but there are some errors occur when building process,So that it cannot

be compiled.How to solve it ?And I found that the DPDK compiling twice when executing

vpp compiling.

 

By the way, I have tried to compile high version(Branch origin/github.qoriq-os/20.11-qoriq)

DPDK using meson, and it does work well,but there are no place to add such “EXTRA_CFLAGS='-g

 -Ofast -fPIC -ftls-model=local-dynamic'” command line when using Makefile method. so that

there are no dpdk vpp-plugin generated,How to build the plugin out?

 

Best wishes.

 

============Test Environment==========

PC: Ubuntu18.04

Board: LS1043ARDB

Software: LSDK 20.12 (using flexbuild_lsdk2012.tgz)(20.04 exists the similar problem)

 

============Documents steps==========

  1. Setup flexbuild environment
        <Fetch Flexbuild as per steps in LSDK Documentation>
        cd flexbuild_<version>
        source setup.env
    2. Enable VPP in Flexbuild
        By default VPP is not enabled for compilation/packaging in Flexbuild. This can be enabled by setting     the following in the
        build configuration file ( build_lsdk.cfg
        CONFIG_APP_VPP=y
    3. Compile VPP
        flex-builder -c vpp
        After this step, the debian package files deb would be available in the       build/apps/components_LS_arm64/usr/local/vpp/ . Then, using the merge-components this would be available in rootfs in /usr/local/vpp

 

==============Error logs==============

fault-jdk-headless is already the newest version (2:1.11-68ubuntu1~18.04.1).

git is already the newest version (1:2.17.1-1ubuntu0.8).

libssl-dev is already the newest version (1.1.1-1ubuntu2.1~18.04.9).

uuid-dev is already the newest version (2.31.1-0.4ubuntu3.7).

libconfuse-dev is already the newest version (3.2.1+dfsg-4ubuntu0.1).

python-pip is already the newest version (9.0.1-2.3~ubuntu1.18.04.4).

cmake is already the newest version (3.10.2-1ubuntu2.18.04.1).

debhelper is already the newest version (11.1.6ubuntu2).

dkms is already the newest version (2.3-3ubuntu9.7).

libnuma-dev is already the newest version (2.0.11-2.1ubuntu0.1).

clang-format is already the newest version (1:6.0-41~exp5~ubuntu1).

dh-systemd is already the newest version (11.1.6ubuntu2).

git-review is already the newest version (1.27.0-0ubuntu0.18.04.1).

The following packages were automatically installed and are no longer required:

  gir1.2-geocodeglib-1.0 libegl1-mesa libwayland-egl1-mesa ubuntu-web-launchers

Use 'sudo apt autoremove' to remove them.

0 upgraded, 0 newly installed, 0 to remove and 9 not upgraded.

make[2]: Leaving directory '/home/j/wk/flex/flexbuild_lsdk2012/packages/apps/networking/vpp'

make[2]: Entering directory '/home/j/wk/flex/flexbuild_lsdk2012/packages/apps/networking/vpp/build-root'

rm -rf /home/j/wk/flex/flexbuild_lsdk2012/packages/apps/networking/vpp/build-root/build-*/

rm -rf /home/j/wk/flex/flexbuild_lsdk2012/packages/apps/networking/vpp/build-root/build-tool-*

rm -rf /home/j/wk/flex/flexbuild_lsdk2012/packages/apps/networking/vpp/build-root/install-*

rm -rf /home/j/wk/flex/flexbuild_lsdk2012/packages/apps/networking/vpp/build-root/images-*

rm -rf /home/j/wk/flex/flexbuild_lsdk2012/packages/apps/networking/vpp/build-root/tools

rm -rf /home/j/wk/flex/flexbuild_lsdk2012/packages/apps/networking/vpp/build-root/*.deb

rm -rf /home/j/wk/flex/flexbuild_lsdk2012/packages/apps/networking/vpp/build-root/*.rpm

rm -rf /home/j/wk/flex/flexbuild_lsdk2012/packages/apps/networking/vpp/build-root/*.changes

rm -rf /home/j/wk/flex/flexbuild_lsdk2012/packages/apps/networking/vpp/build-root/python

if [ -e /usr/bin/dh ];then (cd /home/j/wk/flex/flexbuild_lsdk2012/packages/apps/networking/vpp/build-root/deb/;debian/rules clean); fi

make[3]: Entering directory '/home/j/wk/flex/flexbuild_lsdk2012/packages/apps/networking/vpp/build-root/deb'

dh clean --with systemd,python2 --buildsystem=pybuild

tail: cannot open 'debian/changelog' for reading: No such file or directory

dpkg-parsechangelog: error: tail of debian/changelog subprocess returned exit status 1

   dh_auto_clean -O--buildsystem=pybuild

I: pybuild base:217: python setup.py clean 

running clean

removing '/home/j/wk/flex/flexbuild_lsdk2012/packages/apps/networking/vpp/build-root/deb/.pybuild/cpython2_3.6_vpp-api-python/build' (and everything under it)

'build/bdist.linux-x86_64' does not exist -- can't clean it

'build/scripts-2.7' does not exist -- can't clean it

   dh_clean -O--buildsystem=pybuild

make[3]: Leaving directory '/home/j/wk/flex/flexbuild_lsdk2012/packages/apps/networking/vpp/build-root/deb'

rm -f /home/j/wk/flex/flexbuild_lsdk2012/packages/apps/networking/vpp/build-root/deb/debian/*.install

rm -f /home/j/wk/flex/flexbuild_lsdk2012/packages/apps/networking/vpp/build-root/deb/debian/changelog

make[2]: Leaving directory '/home/j/wk/flex/flexbuild_lsdk2012/packages/apps/networking/vpp/build-root'

make[2]: Entering directory '/home/j/wk/flex/flexbuild_lsdk2012/packages/apps/networking/vpp/build-root'

make[2]: *** No rule to make target 'vpp-package-deb'.  Stop.

make[2]: Leaving directory '/home/j/wk/flex/flexbuild_lsdk2012/packages/apps/networking/vpp/build-root'

ls: cannot access '/home/j/wk/flex/flexbuild_lsdk2012/build/rfs/rootfs_lsdk2012_ubuntu_main_arm64/usr/local/vpp': No such file or directory

Reading package lists... Done

Building dependency tree       

Reading state information... Done

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

 Build vpp  [Done] 

make[1]: Leaving directory '/home/j/wk/flex/flexbuild_lsdk2012/packages/apps'

make: Leaving directory '/home/j/wk/flex/flexbuild_lsdk2012'

Have a good day.
Tags (4)
0 Kudos
3 Replies

173 Views
yipingwang
NXP TechSupport
NXP TechSupport

Please refer to the attached document to compile VPP v2005 in LSDK20.12 build environment.

0 Kudos

162 Views
ELLIOTT
Contributor III

Hi YiPing,

  I just build according your document. But there are some errors occured ,

such like "dpkg: error processing package vpp-plugin-dpdk (--install):",etc.

More details are in the Compling_log_1.txt.

And Debian Images did generated in the ./build/rfs/rootfs_lsdk2012_ubuntu_main_arm64/usr/local/vpp/

But,When I try to install and execute vpp suit,It cant work!Errors occured in

unpacking process and executing vpp app. more details are in the installing_and_running_log_1.txt.

 

Best wishes,

Jack.

Have a good day.
0 Kudos

140 Views
yipingwang
NXP TechSupport
NXP TechSupport

Please refer to the following update from the Linux SDK development team.

From logs It appears, you are trying to install VPP v20.05 over pre-installed VPP  v19.06 on same rootfs. This is not expected situation.

You should flash a fresh rootfile system where VPP v19.06 debains are not installed. Then only install VPP v20.05

 

Also, we are very close to make VPP v21.01 functional and can provide a functional code drop with in 1 week or so. It will be good if you can migrate to this  latest version.

0 Kudos