The LS1012ARDB TX network is very slow

cancel
Showing results for 
Search instead for 
Did you mean: 

The LS1012ARDB TX network is very slow

881 Views
jasonwu0527
Contributor I

   I used iperf testing network throughput, client is LS1012ARDB and server is Ubuntu 16.04, the test results are 23 Mbits, following is iperf logs:
[ 3] 0.0-300.0 sec 824 MBytes 23.0 Mbits/sec

   I exchange iperf server and client, server is Ubuntu and client is LS1012ARDB, re-test, following is iperf logs:
[ 5] 0.0-300.0 sec 29.6 GBytes 848 Mbits/sec

   In addition I tested HTTP file transfer, the LS1012ARDB is HTTP server, download the HTTP file with the google chrome, about speed 4-11 Kbytes,

192074_192074.jpgcats3.jpg

 

Ubuntu firefox  HTTP download speed is Unstable, most of them are 5xx ~ 9xx Kbytes, sometimes 2x Mbytes,

192075_192075.pngScreenshot from 2017-08-18 16-24-28.png

192089_192089.jpgcats6.jpg

 


Why is the LS1012ARDB TX network speed so slow? Please help me.

I have uploaded a detailed log file.

 

FIRMWARE: /flash-image/LS1012A_SDK_LS1012ARDB_20161230_QSPI_Flash.bin  in LS1012A-SDK-AARCH64-IMAGE-20161230-yocto.iso.

 

LS1012ARDB board700-28872 REV B, SCH28872 REV D.

Original Attachment has been moved to: ls1012ardb_ethernet_tx_iperf_http_test.log.zip

Labels (1)
Tags (2)
0 Kudos
4 Replies

229 Views
yipingwang
NXP TechSupport
NXP TechSupport

Hello Jason Wu,

The iperf test data is abnormal when LS1012ARDB is used as the client.

Please refer to the following test data we got in EAR 0.5 test.

Did you perform iperf client and server test on LS1012ARDB under the same boot Linux system without reboot?

Because I didn't find eth1 pfe open information when doing iperf client test.

 

IPERF/IPERF3

 

 

Command

The size for buffer (-l)

Bandwidth(Mbits/sec)

With PFE 
NotSet optimization parameters

UDP

iperf -c 10.193.21.79 -u -b 1G 

NA

803

iperf3 -c 10.193.21.79 -u -b 1G 

NA

996

TCP

iperf -c 10.193.21.79 -t 100 -P 20

NA

934

iperf3 -c 10.193.21.79 -t 100 -P 20

NA

940

 


Have a great day,
TIC

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

229 Views
jasonwu0527
Contributor I

Hi Yiping,

   Thank you for your reply, but I can no't find the EAR 0.5 version download link on the "QorIQ Linux SDK v2.0 Download" site,

    Where to download the EAR 0.5 version?

     Thank you.

   cats.jpg

0 Kudos

229 Views
mdecandia
Contributor I

Hi Jason, 

do you have any ipdate on this topic? We are testing the same issue.

Michele

0 Kudos

229 Views
jasonwu0527
Contributor I

Thank you for your help.

I re-tested according to your iperf parameters.
Ubuntu and Windows 10 are different computers.
The speed of the network is not good.
Please help me.

I can not find the  LS1012ARDB 0.5 version download URL, so use 2.0-1703 versions of the test.

FW:  QorIQ_SDK_V2.0_LS1012ARDB_20170331_QSPI_Flash.bin in QorIQ Linux SDK v2.0-1703.tar.bz2 

cats5.jpg

cats6.jpg

cats4.jpg


1. Ubuntu 16.04 (Computer A):

  iperf3:
  root@ls1012ardb:~# iperf3 -c 192.168.2.100 -t 100 -p 20

  test 1:
    [ 4] 0.00-100.00 sec 239 MBytes 20.1 Mbits/sec 605 sender
    [ 4] 0.00-100.00 sec 238 MBytes 20.0 Mbits/sec receiver
  test 2:
    [ 4] 0.00-100.00 sec 250 MBytes 20.9 Mbits/sec 582 sender
    [ 4] 0.00-100.00 sec 249 MBytes 20.9 Mbits/sec receiver

   iperf:

  root@ls1012ardb:~# iperf -c 192.168.2.100 -t 100 -p 20

  test 1:
    [ 3] 0.0-100.5 sec 314 MBytes 26.2 Mbits/sec
  test 2:
    [ 3] 0.0-100.0 sec 391 MBytes 32.8 Mbits/sec

2. Windows 10 (Computer B):
  HTTP:
  LS1012ARDB:
      /usr/sbin/httpd -p 80 -h /media/SSD
  Windows 10 Google chrome:

cats.jpg

cats1.jpg

  FTP:
    LS1012ARDB:
        tcpsvd 0 21 ftpd -w /media/SSD &

    Windows 10 FileZilla clinet:

cats3.jpg

cats2.jpg



3. LS1012ARDB ETH1 -> Synology Router RT2600ac -> iPad 2 VLC play a mp4 video:

  eth1 TX speed : 4 ~ 10 Kbytes.

4. Ethernet info:
root@ls1012ardb:~# ifconfig
eth0 Link encap:Ethernet HWaddr 00:04:9f:04:68:b3
inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::204:9fff:fe04:68b3/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:258 (258.0 B)
eth1 Link encap:Ethernet HWaddr 00:04:9f:04:68:b1
inet addr:192.168.2.1 Bcast:192.168.2.255 Mask:255.255.255.0
inet6 addr: fe80::204:9fff:fe04:68b1/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:238660 errors:0 dropped:0 overruns:0 frame:0
TX packets:1058007 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:15704984 (14.9 MiB) TX bytes:1601095270 (1.4 GiB)
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:57 errors:0 dropped:0 overruns:0 frame:0
TX packets:57 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:7605 (7.4 KiB) TX bytes:7605 (7.4 KiB)

root@ls1012ardb:~# ethtool eth1
Settings for eth1:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Supported pause frame use: No
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Link partner advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Link partner advertised pause frame use: Symmetric Receive-only
Link partner advertised auto-negotiation: Yes
Speed: 1000Mb/s
Duplex: Full
Port: MII
PHYAD: 1
Transceiver: external
Auto-negotiation: on
Current message level: 0x00000036 (54)
probe link ifdown ifup
Link detected: yes

0 Kudos