QorIQ SDK 2.0 create error in Ubuntu 18 and 20

cancel
Showing results for 
Search instead for 
Did you mean: 

QorIQ SDK 2.0 create error in Ubuntu 18 and 20

78 Views
winstonjacob
Contributor III

I want to use the QorIQ SDK 2.0 in Ubuntu 18.04 for ls1021a, but its throwing error while setting up. SO is their any possibility to use Ubuntu 18 and 20.

 

Regards

Winston

0 Kudos
1 Reply

69 Views
Pavel
NXP TechSupport
NXP TechSupport

Use Ubuntu 14 for SDK building. Do not use Ubuntu 16 or Ubuntu 18.

The following command sequence was used under Ubuntu 14:

 

  1.             sudo apt-get install ubuntu-minimal ubuntu-standard patch vim-common sed wget subversion git-core coreutils libbonobo2-common unzip texi2html texinfo libsdl1.2-dev docbook-utils gawk python-pysqlite2 diffstat make gcc build-essential xz-utils g++ desktop-file-utils chrpath libgl1-mesa-dev libglu1-mesa-dev autoconf automake groff libtool xterm libncurses5-dev cvs tofrodos

 

  1.             a) command: ls -l /bin/sh

                Message:  /bin/sh -> dash

  1.             b) command: sudo dpkg-reconfigure dash

                Answer after password – No

                Message:

                Removing 'diversion of /bin/sh to /bin/sh.distrib by dash'

                Adding 'diversion of /bin/sh to /bin/sh.distrib by bash'

                Removing 'diversion of /usr/share/man/man1/sh.1.gz to /usr/share/man/man1/sh.distrib.1.gz by dash'

                Adding 'diversion of /usr/share/man/man1/sh.1.gz to /usr/share/man/man1/sh.distrib.1.gz by bash'

  1.             c) command for checking: ls -l /bin/sh

                Message: /bin/sh -> bash

 

  1.             mount SDK source .iso file
  2.             cd <sdk-install-dir>.
  3.             ./sources/meta-freescale/scripts/host-prepare.sh

Usually Linux recommends also run the following command: sudo usr/sbin/visudo

  1. Install SDK 2.0-1703
  2. . fsl-setup-env -m ls1043ardb
  3. bitbake fsl-image-minimal

 

Linux kernel code is available using the following path:

/QorIQ-SDK-V2.0-20160527-yocto/build_ls1043ardb/tmp/work/ls1043ardb-fsl-linux/linux-qoriq/4.1-r0/git

 

Source code of u-boot is available using the following path:

/QorIQ-SDK-V2.0-20160527-yocto/build_ls1046ardb/tmp/work/ls1046ardb-fsl-linux/u-boot-qoriq/2016.09+fslgit-r0/git

 

Note: NXP offers also Yocto SDK 2.7:

https://source.codeaurora.org/external/qoriq/qoriq-components/yocto-sdk/about/

 

This SDK can be used under Ubuntu 16, 18 and 20

0 Kudos