QorIQ GA 16.09 release unable to access meta-nxp-npi or sw-stash.freescale.net, is this needed?

cancel
Showing results for 
Search instead for 
Did you mean: 

QorIQ GA 16.09 release unable to access meta-nxp-npi or sw-stash.freescale.net, is this needed?

Jump to solution
886 Views
pro-supportengi
NXP Employee
NXP Employee

After downloading and installing the SDK2.0-1609 release, in sources/meta-nxp-npi-1609/README the following instructions to pull and build SDK2.0-1609 are given.  But the git clone fails because the stash server is unavailable.

1) To properly update and build the 1609 release, is it necessary to git clone and link as the instructions indicate below (lines 4 and 5)? 

2) If not required, why are the instructions given?

3) If required, how can customers clone http://sw-stash.freeschale.net if the server is not available per the instructions below?

NXP's QorIQ SDK Project
=============================
This is GA 16.09 release which based on SDK v2.0.

Steps to build:
1. Install SDK 2.0 source ISO
2. Install SDK 2.0 aarch64 cache ISO #optional, to speed up build
3. $ cd <iso_install_location>/QorIQ-SDK-V2.0-20160527-yocto/sources/
4. $ git clone http://sw-stash.freescale.net/scm/dnyocto/meta-nxp-npi -b jethro-sdk-v2.0-ga-16.09 meta-nxp-npi-ga
5. $ ln -s meta-nxp-npi-ga meta-fsl-local-build #a hack as meta-nxp-npi layer is not included in fsl-setup-env script by default
6. $ cd <iso_install_location>/QorIQ-SDK-V2.0-20160527-yocto/
7. $ . ./fsl-setup-env -m <board>
8. $ bitbake <target>

~/neo_mcu_eos-qoriq_v2_sources/sources$ git clone http://sw-stash.freescale.net/scm/dnyocto/meta-nxp-npi -b jethro-sdk-v2.0-ga-16.09 meta-nxp-npi-ga
Cloning into 'meta-nxp-npi-ga'...
fatal: unable to access 'http://sw-stash.freescale.net/scm/dnyocto/meta-nxp-npi/': Could not resolve host: sw-stash.freescale.net

How do customer's resolve the host sw-stash.freescale.net?

Labels (2)
0 Kudos
1 Solution
597 Views
yipingwang
NXP TechSupport
NXP TechSupport

Hello pro-supportengineer,

I just confirmed with the Yocto SDK production team. This is a defect of the README file, please suggest customers use this git tree address "git://git.freescale.com/yocto/meta-nxp-npi.git".


Have a great day,
Yiping

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
2 Replies
598 Views
yipingwang
NXP TechSupport
NXP TechSupport

Hello pro-supportengineer,

I just confirmed with the Yocto SDK production team. This is a defect of the README file, please suggest customers use this git tree address "git://git.freescale.com/yocto/meta-nxp-npi.git".


Have a great day,
Yiping

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos
597 Views
pro-supportengi
NXP Employee
NXP Employee

git clone git://git.freescale.com/yocto/meta-nxp-npi.git correctly clones the meta-nxp-npi, but the SDK2.0-1609 install was updated prior to release to install meta-nxp-npi from the compressed image and to rename to source/meta-nxp-npi-1609.  So, the README instructions are incorrect and are no longer necessary.  No need to git clone git://git.freescale.com/yocto/meta-nxp-npi.git.

The README is stale and should be deprecated.