QSPI Flash Speeds for the LS1046ARDB

cancel
Showing results for 
Search instead for 
Did you mean: 

QSPI Flash Speeds for the LS1046ARDB

301 Views
Contributor I

Hi,

We are using a custom basic bootloader on the LS1046ARDB. We find on our board that copying an 8MB Application from the QSPI Flash to DDR RAM takes about 48s, which works out to ~ 0.16 MB/sec (using a standard implementation of the memcpy function) 

Are these in line with expected speeds?

How can we check the current "mode" (Single, dual, quad modes of operation, as mentioned in Section 27.2.1 of the LS1046ARM Ref Manual) of the QSPI Flash? 

We changed SCFG_QSPI_CFG[CLK_SEL] value to 0x4 (highest working value) to change the QSPI Clock divider value to 20, and found a moderate improvement in speed. The copy time for the same 8MB file came down to 30s, working out to ~ 0.26 MB/sec. Please suggest any other modifications/ configurations we can look at to further speed up QSPI Flash Read speeds.

Thanks,

Shivesh

chitra.amzarewale@utas.utc.com

Labels (1)
0 Kudos
8 Replies

148 Views
NXP TechSupport
NXP TechSupport

LUT0

INSTR0; PAD0; OPRND0 - 0x0413

INSTR0 - 1 (it is CMD); PAD0 - 00; OPRND0 - 0x13

It means:

CMD - the first operation is send command

length of command 1 byte

value of this command is 0x13

 

INSTR1; PAD1; OPRND1 - 0x0820

INSTR1 - 2 (it is ADDR); PAD0 - 00; OPRND0 - 0x20

It means:

ADDR for QSPI operations

length of address is 32bits (0x20)

Have a great day,
Pavel Chubakov

0 Kudos

148 Views
NXP TechSupport
NXP TechSupport

Sorry.

See the Section 27.4.2.30 of the LS1046a Reference Manual rev 2.1:

https://www.nxp.com/webapp/Download?colCode=LS1046ARM

Have a great day,
Pavel Chubakov

0 Kudos

148 Views
Contributor I

Hi Pavel, 

We tried using the default values however it is causing the flash to be read incorrectly. Below are the LUT0, LUT1 default values being programmed by our Lauterbach Debugger that read correctly - 

LUT0 - 0x08200413 (default value mentioned in LS1046ARM : 0x08180403)

LUT1 - 0x24001C08 (default value mentioned in LS1046ARM : 0x24001C08)

Can you suggest any modifications to these that won't cause incorrect reads?

0 Kudos

148 Views
NXP TechSupport
NXP TechSupport

See the Section 30.4.2.30 of the LS1046a Reference Manual:

https://www.nxp.com/webapp/Download?colCode=LS1046ARM

Have a great day,
Pavel Chubakov

0 Kudos

148 Views
Contributor I

Hi Pavel,

The Section you have mentioned (30.4.2.30) does not exist in the LS1046a Reference Manual.

Regards,

Shivesh

0 Kudos

148 Views
NXP TechSupport
NXP TechSupport

Check LUT setting in your bootloader. See the Sections 27.4.2.30 and 27.6.3.1 in the LS1046a Reference Manual:

https://www.nxp.com/webapp/Download?colCode=LS1046ARM

Have a great day,
Pavel Chubakov

 

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

148 Views
Contributor I

Hi Pavel,

What are the default LUT settings for the LS1046ARDB?

Thanks,

Shivesh

0 Kudos

148 Views
Contributor I

Hello Yiping, NXP community

 

Request you to respond to the above question. For us startup time is very important and QSPI speed is crucial to achieve required timing, your response will help us greatly.

 yiping wang‌

Thanks

Chitra Amzarewale

shivesh.sood@collins.com

0 Kudos