Plans in regards to Layerscape devices (i.e. LS1028A) in the Trusted Firmware-A repositories

cancel
Showing results for 
Search instead for 
Did you mean: 

Plans in regards to Layerscape devices (i.e. LS1028A) in the Trusted Firmware-A repositories

Jump to solution
44 Views
Joris_V
Contributor I

Hi,

The current QorIQ Layerscape ATF repository on codeaurora appears to be still at version 1.5, whilst the upstream is already at V2.4. The upstream repository supports only a limited amount of Layerscape devices and features in comparison to the other.

Are there plans to get the codeaurora repository to a more recent version (i.e. V2.4) soon? Or perhaps is this already available somewhere?

And will more Layerscape devices such as the LS1028A be made available in the upstream repository?

Thanks!

 

Best regards,

Joris

Labels (1)
0 Kudos
1 Solution
27 Views
yipingwang
NXP TechSupport
NXP TechSupport

In LSDK2012 we only support lx2 for v2.4, but currently we have already enabled all layerscape platforms for tf-a version 2.4 except ls1021a which is armv7, we plan to release v2.4 for all platforms in next LSDK release.

About upstream,  lx2160 and lx2162 have been merged by upstream community, ls1046a is in review progress, all the other platforms will be upstreamed in this year after ls1046a will be merged.

View solution in original post

1 Reply
28 Views
yipingwang
NXP TechSupport
NXP TechSupport

In LSDK2012 we only support lx2 for v2.4, but currently we have already enabled all layerscape platforms for tf-a version 2.4 except ls1021a which is armv7, we plan to release v2.4 for all platforms in next LSDK release.

About upstream,  lx2160 and lx2162 have been merged by upstream community, ls1046a is in review progress, all the other platforms will be upstreamed in this year after ls1046a will be merged.

View solution in original post