LS1046ARDB Net-SNMP service is not able to run

cancel
Showing results for 
Search instead for 
Did you mean: 

LS1046ARDB Net-SNMP service is not able to run

Jump to solution
169 Views
Ghouse
Contributor I

In LS1046A Evaluation Board I am using Ubuntu 18.04 ISO bootable image, once device is up, I am going to send gcc-linaro cross compiled desktop version successfully to specified target location.

i.e iam able to cross compile in Desktop machine using gcc-linaro using  "./configure  --prefix=/snmp/ --host=arm" command, then followed by make and make install, then target snmp folder as compressed to snmp.tar.gz.

This snmp.tar.gz i am sending to target NXPdevice (EVAL board) using scp command using Ethernet connection. target location (here location as root  /) uncompressed the snmp.tar.gz file. then I will get snmp folder, now inside  /sbin/snmpd  iam trying to run but I am not able to run snmpd service in NXP. it is saying sh:"snmpd: command not found", it has not identify the snmpd as a service. here attachments.

Please provide your help.

0 Kudos
1 Solution
164 Views
yipingwang
NXP TechSupport
NXP TechSupport

Please run command "./snmpd".

Please cross compile Net-SNMP with aarch64 toolchain. The toolchain which you are using is for aarch32 platform.

You could download ARM aarch64 toolchain from the following link, then run ./fsl-qoriq-glibc-x86_64-fsl-toolchain-aarch64-toolchain-3.0.sh to install aarch64 toolchain, then run "source /opt/fsl-qoriq/3.0/environment-setup-aarch64-fsl-linux" to deploy toolchain build environment.

https://drive.google.com/file/d/13TuXjryONyxXRJeNlKm87WICTlNYtLP4/view?usp=sharing

View solution in original post

0 Kudos
2 Replies
165 Views
yipingwang
NXP TechSupport
NXP TechSupport

Please run command "./snmpd".

Please cross compile Net-SNMP with aarch64 toolchain. The toolchain which you are using is for aarch32 platform.

You could download ARM aarch64 toolchain from the following link, then run ./fsl-qoriq-glibc-x86_64-fsl-toolchain-aarch64-toolchain-3.0.sh to install aarch64 toolchain, then run "source /opt/fsl-qoriq/3.0/environment-setup-aarch64-fsl-linux" to deploy toolchain build environment.

https://drive.google.com/file/d/13TuXjryONyxXRJeNlKm87WICTlNYtLP4/view?usp=sharing

View solution in original post

0 Kudos
150 Views
Ghouse
Contributor I

Thank you for the support.

 I have followed above steps once configuring cross-compiler I am getting following error.

here are the attachments.

0 Kudos