I use openwrt to build the sd card image. But the prompt cannot be started.

cancel
Showing results for 
Search instead for 
Did you mean: 

I use openwrt to build the sd card image. But the prompt cannot be started.

712 Views
suyunfa
Contributor I

ERROR: First slot cannot be empty.
ERROR: Parsing DIMM Error
ERROR: DDR init failed.
NOTICE: Incorrect DRAM0 size is defined in platfor_def.h
ERROR: mmap_add_region_check() failed. error -22
ERROR: mmap_add_region_check() failed. error -22
NOTICE: BL2: v1.5(release):reboot-15563-g3bd8f660a4-dirty
NOTICE: BL2: Built : 12:30:20, Jan 21 2021

I chose the sd card of uboot 1046 to boot. And successfully got openwrt-0.78.1-510a9df2-r15563-3bd8f660a4-layerscape-armv8_64b-fsl_ls1046a-rdb-sdboot-squashfs-sdcard.img
With openwrt-0.78.1-510a9df2-r15563-3bd8f660a4-layerscape-armv8_64b-fsl_ls1046a-rdb-initramfs-kernel.bin
I used penwrt-0.78.1-510a9df2-r15563-3bd8f660a4-layerscape-armv8_64b-fsl_ls1046a-rdb-sdboot-squashfs-sdcard.img
Burn into the tf card. But it prompted an error.
Cannot start normally. Ask for help.
My development board is https://www.forlinx.com/product/ls1046a-22.html

 

0 Kudos
9 Replies

672 Views
suyunfa
Contributor I

Can't I use the official master of Openwrt? Because all my software is based on openwrt official. Is there any good way?

0 Kudos

665 Views
yipingwang
NXP TechSupport
NXP TechSupport

I discussed with OpenWrt development team.

You could use master of Openwrt downloaded from https://github.com/openwrt/openwrt.git, which includes Linux Kernel 5.4.

However only the following release has been tested by NXP testing team.

https://source.codeaurora.org/external/qoriq/qoriq-components/openwrt/

tag: layerscape-20.09

Tags (1)
0 Kudos

663 Views
suyunfa
Contributor I

Thank you very much for your answer. I will continue to test. thank you very much。

NXP’s community is very friendly.

0 Kudos

702 Views
suyunfa
Contributor I

https://github.com/openwrt/openwrt.git

I build from openwrt.
Cannot select ext4 file system. Will go wrong.
All others use the default parameter settings.

 

0 Kudos

682 Views
yipingwang
NXP TechSupport
NXP TechSupport

In OpenWrt squashfs is used for QSPI flash, ext4 is used by SD card.

Please refer to the following procedure to build SD image in OpenWrt.

$ git clone https://github.com/openwrt/openwrt.git

$ git checkout -b openwrt-19.07 origin/openwrt-19.07

$ make menuconfig

Please configure "Target System" as "NXP Layerscape", configure "Target Profile" as "LS1046ARDB (SD Card Boot))", then run make to  build the final image.

0 Kudos

666 Views
suyunfa
Contributor I

Thank you very much for your answers. For the time being, I have no better way.

0 Kudos

676 Views
suyunfa
Contributor I

I need kernel 5.4

0 Kudos

674 Views
yipingwang
NXP TechSupport
NXP TechSupport
Tags (1)
0 Kudos

678 Views
suyunfa
Contributor I

Must it be openwrt-19.07? Doesn't it support master?

0 Kudos