[Failed] notification of LSDK19.09 on LS1028ARDB

cancel
Showing results for 
Search instead for 
Did you mean: 

[Failed] notification of LSDK19.09 on LS1028ARDB

138 Views
Contributor III

Hi all,

I deployed the LSDK19.09 by flex-installer successfully. But after I start the system from SD card boot, it continuously report errors as below:

"

[FAILED] Failed to mount Mount unit for core, revision 6533.
See 'systemctl status snap-core-6533.mount' for details.

"

Do you have any idea?

Thanks

   Yi

pastedImage_2.png

pastedImage_1.png

Tags (1)
0 Kudos
9 Replies

3 Views
NXP TechSupport
NXP TechSupport

Hello Yi Yu,

Please refer to my attached log, booting the system with ubuntu:mate rootfs, I didn't reproduce your problem, the filesystem worked normally.

Please generate rootfs with the following command.

$ flex-builder -i mkrfs -r ubuntu:mate

$ flex-builder -i merge-component -r ubuntu:mate

$ flex-builder -i packrfs -r ubuntu:mate

Thanks,

Yiping

0 Kudos

3 Views
Contributor III

Hi Yiping,

I am sure about the procedures for deploying image on SD card, i.e.

-- flex-builder -i mkrfs -a arm64 -m ls1028ardb -r ubuntu:mate

-- flex-builder -c linux -a arm64 -m ls1028ardb -r ubuntu:mate

-- flex-builder -i mkbootpartition -a arm64 -m ls1028ardb -r ubuntu:mate

-- flex-builder -i mkfw -a arm64 -m ls1028ardb -r ubuntu:mate

-- flex-builder -i merge-component -a arm64 -m ls1028ardb -r ubuntu:mate

-- flex-builder -i packrfs -a arm64 -m ls1028ardb -r ubuntu:mate

The starting log is attached for your information. I did not find special difference from yours. Do you know what is the "Mounting Mount unit for core, revision 6533..."?

pastedImage_2.png

NXP LSDK Mate 1909 (based on Ubuntu-Mate) ubuntu-mate ttyS0
ubuntu-mate login: root
Welcome to Ubuntu 18.04.2 LTS (GNU/Linux 4.19.68 aarch64)

 * Documentation:  https://help.ubuntu.com
 * Management:     https://landscape.canonical.com
 * Support:        https://ubuntu.com/advantage

372 packages can be updated.
214 updates are security updates.

The programs included with the Ubuntu system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Ubuntu comes with ABSOLUTELY NO WARRANTY, to the extent permitted by
applicable law.

Mounting Mount unit for core, revision 6533...
[FAILED] Failed to mount Mount unit for core, revision 6533.
See 'systemctl status snap-core-6533.mount' for details.
[ TIME ] Timed out waiting for device dev-serial1.device.
[DEPEND] Dependency failed for Configure Bluetooth Modems connected by UART.
         Starting Message of the Day...
[  OK  ] Started Message of the Day.

0 Kudos

3 Views
NXP TechSupport
NXP TechSupport

It seems that Kernel doesn't support squashfs, which is a requirement for snaps.

0 Kudos

3 Views
Contributor III

Hi Yiping,

I checked my linux config by "flex-builder -c linux:custom" and it showed "SQUASHFS [= y]" etc.

Could you help to check the your configurations to identify the difference from mine?

Thanks,

   Yi

pastedImage_1.pngpastedImage_1.png

pastedImage_2.pngpastedImage_4.png

pastedImage_5.pngpastedImage_6.png

0 Kudos

3 Views
NXP TechSupport
NXP TechSupport

Please try to remove gnome-software-plugin-snap.

$ apt remove gnome-software-plugin-snap

0 Kudos

3 Views
Contributor III

Hi Yiping,

I tried the removal of snap plugin, rebuilt the rfs, linux kernel, mkbootpartition, merge-component, packrfs. But it did not take effect.

Thanks for your help

   Yi

0 Kudos

3 Views
NXP TechSupport
NXP TechSupport

Please run command "systemctl status snap-core-6533.mount" for detailed information.

0 Kudos

3 Views
Contributor III

Hi Yiping,

 

The detailed information is as below.

Thanks,

   Yi

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

root@ubuntu-mate:~# systemctl status snap-core-6533.mount
? snap-core-6533.mount
   Loaded: not-found (Reason: No such file or directory)
   Active: failed (Result: exit-code) since Sun 2018-01-28 15:59:15 UTC; 1min 35

Jan 28 15:59:15 ubuntu-mate systemd[1]: Mounting Mount unit for core, revision 6
Jan 28 15:59:15 ubuntu-mate mount[4394]: mount: /snap/core/6533: wrong fs type,
Jan 28 15:59:15 ubuntu-mate systemd[1]: snap-core-6533.mount: Mount process exit
Jan 28 15:59:15 ubuntu-mate systemd[1]: snap-core-6533.mount: Failed with result
Jan 28 15:59:15 ubuntu-mate systemd[1]: Failed to mount Mount unit for core, rev

0 Kudos

3 Views
NXP TechSupport
NXP TechSupport
0 Kudos