FM QMAN Init Failed at boot-up - FqAlloc: Memory Allocation Failed

cancel
Showing results for 
Search instead for 
Did you mean: 

FM QMAN Init Failed at boot-up - FqAlloc: Memory Allocation Failed

430 Views
vigneshr
Contributor III

Hi,

I'm adding board support for ls1043ardb with 3.14 kernel support. I have ported all required files and during boot-up I do face some FMAN issue failed to allocate memory as per log.

21c0600.serial: ttyS1 at MMIO 0x21c0600 (irq = 86, base_baud = 25000000) is a 16550A
serial: Freescale lpuart driver
brd: module loaded
loop: module loaded
CAN device driver interface
Freescale FM module FMD API version 21.1.0
cpu 1: ! MAJOR FM Error [CPU01, drivers/net/ethernet/freescale/fman/src/wrapper/lnxwrp_fm_port.c:207 FqAlloc]: Memory Allocation Failed;
cpu 1: FQ obj - qman_init_fq!!!cpu 1:

I have used updated u-boot and below rcw & fman.

RCW: rcw_1600.bin

Fm-Ucode: fsl_fman_ucode_ls1043_r1.0_108_4_9.bin

DTS: fsl-ls1043ardb-aarch32.dts

I have used these same RCW, DTS and FMAN for 3.19 kernel and it was booted successfully with ethernet support.

On further analysis on issue in qman_init_fq function, it is failed at below part of code,

while (!(mcr = qm_mc_result(&p->p)))
cpu_relax();
DPA_ASSERT((mcr->verb & QM_MCR_VERB_MASK) == myverb);
res = mcr->result;

if (res != QM_MCR_RESULT_OK) {
FQUNLOCK(fq);
PORTAL_IRQ_UNLOCK(p, irqflags);
put_affine_portal();
return -EIO;
}

It returned EIO and the qman_init_fq function is failed. The value which receives for res is f2 which is pointing QM_MCR_RESULT_ERR_FQSTATE.

Please suggest me what could be the cause for issue and how to overcome this issue.

PFA kernel config, bootup log and dtsi file. Kindly please do the needful, thanks in advance :smileyhappy:

Regards,

Vigneshwaran R

Labels (1)
0 Kudos
3 Replies

150 Views
vigneshr
Contributor III

Hi All,

I have solved above mentioned issue. It is due to some of DTC memory allocation files were missing with 3.14 kernel. After added those files, board booted up,

But when I make ethernet interface UP,  I do face below issue, 

random: ubusd urandom read with 0 bits of entropy available procd: - init - Please press Enter to activate this console. fsl_dpa ethernet.13 eth1: Could not connect to PHY /fman@1a00000/mdio@fc000/ethernet-phy@4 fsl_dpa ethernet.13 eth1: init_phy() = -19

Could you please help, what is missing to be added and how to overcome this issue.

Regards,

VIgneshwaran R

0 Kudos

150 Views
bpe
NXP TechSupport
NXP TechSupport

Your DPAA Ethernet driver is unable to communicate with the PHY over the management interface. Make sure the Device Tree properly specifies the PHY

MDIO bus and address. Query the PHY in u-Boot to make sure it responds as expected. See the links below for more information:

http://git.freescale.com/git/cgit.cgi/ppc/sdk/linux.git/tree/Documentation/devicetree/bindings/net/f...
http://git.freescale.com/git/cgit.cgi/ppc/sdk/linux.git/tree/Documentation/devicetree/bindings/net/p...
https://freescale.sdlproducts.com/LiveContent/content/en-US/QorIQ_SDK/GUID-487590EF-7F9D-4B56-BCDF-3...


Have a great day,
Platon

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

150 Views
vigneshr
Contributor III

Hi Platon,

Thanks for your suggestion. I got it work by enabling some of packages in kernel like of_reserve_mem, 10G interface package.

Now I run into PCI interface issues,

I got below issues, please let me know if you have any suggestions.

layerscape-pcie 3500000.pcie: error with ioremap in function
layerscape-pcie 3500000.pcie: failed to initialize host
layerscape-pcie: probe of 3500000.pcie failed with error -12
layerscape-pcie 3600000.pcie: error with ioremap in function
layerscape-pcie 3600000.pcie: failed to initialize host
layerscape-pcie: probe of 3600000.pcie failed with error -12

Also please let me know what are all packages required for PCI.

Thanks,

Vigneshwaran R

0 Kudos