Enable/Disable fm1-mac9 (10G Copper) on LS1043ARDB

cancel
Showing results for 
Search instead for 
Did you mean: 

Enable/Disable fm1-mac9 (10G Copper) on LS1043ARDB

172 Views
ts1234
Contributor III

How do I enable fm1-mac9 on LS1043ARDB?

I am using sd card based build from flexbuild_lsdk2004_update_290520.

All other interfaces (QSGMII.P0,QSGMII.P1,QSGMII.P2,QSGMII.P3,RGMII1 and RGMII2) are working except fm1-mac9. I have tried both DHCP and Static settings.

cat /proc/version
Linux version 5.4.3

root@localhost:~# dmesg | grep eth
[ 0.000000] psci: probing for conduit method from DT.
[ 2.871911] fsl_mac 1ae0000.ethernet: FMan MEMAC
[ 2.876530] fsl_mac 1ae0000.ethernet: FMan MAC address: 00:04:9f:06:d1:73
[ 2.883665] fsl_mac 1ae2000.ethernet: FMan MEMAC
[ 2.888280] fsl_mac 1ae2000.ethernet: FMan MAC address: 00:04:9f:06:d1:74
[ 2.895174] fsl_mac 1ae4000.ethernet: FMan MEMAC
[ 2.899790] fsl_mac 1ae4000.ethernet: FMan MAC address: 00:04:9f:06:d1:75
[ 2.906676] fsl_mac 1ae6000.ethernet: FMan MEMAC
[ 2.911293] fsl_mac 1ae6000.ethernet: FMan MAC address: 00:04:9f:06:d1:76
[ 2.918428] fsl_mac 1ae8000.ethernet: FMan MEMAC
[ 2.923044] fsl_mac 1ae8000.ethernet: FMan MAC address: 00:04:9f:06:d1:77
[ 2.930179] fsl_mac 1aea000.ethernet: FMan MEMAC
[ 2.934794] fsl_mac 1aea000.ethernet: FMan MAC address: 00:04:9f:06:d1:78
[ 2.941686] fsl_mac 1af0000.ethernet: FMan MEMAC
[ 2.946303] fsl_mac 1af0000.ethernet: FMan MAC address: 00:04:9f:06:d1:79
[ 2.958377] fsl_dpa soc:fsl,dpaa:ethernet@0: Skip RX PCD High Priority FQs initialization
[ 2.967816] fsl_dpa: fsl_dpa: Probed interface eth0
[ 2.973110] fsl_dpa soc:fsl,dpaa:ethernet@1: Skip RX PCD High Priority FQs initialization
[ 2.987516] fsl_dpa: fsl_dpa: Probed interface eth1
[ 2.992865] fsl_dpa soc:fsl,dpaa:ethernet@2: Skip RX PCD High Priority FQs initialization
[ 3.002354] fsl_dpa: fsl_dpa: Probed interface eth2
[ 3.007773] fsl_dpa soc:fsl,dpaa:ethernet@3: Skip RX PCD High Priority FQs initialization
[ 3.017342] fsl_dpa: fsl_dpa: Probed interface eth3
[ 3.022826] fsl_dpa soc:fsl,dpaa:ethernet@4: Skip RX PCD High Priority FQs initialization
[ 3.032500] fsl_dpa: fsl_dpa: Probed interface eth4
[ 3.038052] fsl_dpa soc:fsl,dpaa:ethernet@5: Skip RX PCD High Priority FQs initialization
[ 3.047798] fsl_dpa: fsl_dpa: Probed interface eth5
[ 3.053429] fsl_dpa soc:fsl,dpaa:ethernet@8: Skip RX PCD High Priority FQs initialization
[ 3.063273] fsl_dpa: fsl_dpa: Probed interface eth6
[ 3.683246] optee: probing for conduit method from DT.
[ 12.291273] fsl_dpa soc:fsl,dpaa:ethernet@8 fm1-mac9: renamed from eth6
[ 12.333978] fsl_dpa soc:fsl,dpaa:ethernet@0 fm1-mac1: renamed from eth0
[ 12.374366] fsl_dpa soc:fsl,dpaa:ethernet@2 fm1-mac3: renamed from eth2
[ 12.403003] fsl_dpa soc:fsl,dpaa:ethernet@1 fm1-mac2: renamed from eth1
[ 12.437713] fsl_dpa soc:fsl,dpaa:ethernet@3 fm1-mac4: renamed from eth3
[ 12.468623] fsl_dpa soc:fsl,dpaa:ethernet@4 fm1-mac5: renamed from eth4
[ 12.497484] fsl_dpa soc:fsl,dpaa:ethernet@5 fm1-mac6: renamed from eth5
root@localhost:~#

root@localhost:~# ethtool fm1-mac9
Settings for fm1-mac9:
Supported ports: [ ]
Supported link modes: 10000baseT/Full
Supported pause frame use: No
Supports auto-negotiation: No
Supported FEC modes: Not reported
Advertised link modes: 10000baseT/Full
Advertised pause frame use: No
Advertised auto-negotiation: No
Advertised FEC modes: Not reported
Link partner advertised link modes: 1000baseT/Full
Link partner advertised pause frame use: No
Link partner advertised auto-negotiation: No
Link partner advertised FEC modes: Not reported
Speed: Unknown!
Duplex: Unknown! (255)
Port: MII
PHYAD: 1
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: d
Wake-on: d
Current message level: 0xffffffff (-1)
drv probe link timer ifdown ifup rx_err tx_err tx_queued intr tx_done rx_status pktdata hw wol 0xffff8000
Link detected: no
root@localhost:~# ifconfig fm1-mac9
fm1-mac9: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
inet 10.150.0.199 netmask 255.255.0.0 broadcast 10.150.255.255
ether 00:04:9f:06:d1:79 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device memory 0x1af0000-1af0fff


root@localhost:~# ethtool -k fm1-mac9
Features for fm1-mac9:
rx-checksumming: off [fixed]
tx-checksumming: on
tx-checksum-ipv4: on
tx-checksum-ip-generic: off [fixed]
tx-checksum-ipv6: on
tx-checksum-fcoe-crc: off [fixed]
tx-checksum-sctp: off [fixed]
scatter-gather: on
tx-scatter-gather: on
tx-scatter-gather-fraglist: off [fixed]
tcp-segmentation-offload: off
tx-tcp-segmentation: off [fixed]
tx-tcp-ecn-segmentation: off [fixed]
tx-tcp-mangleid-segmentation: off [fixed]
tx-tcp6-segmentation: off [fixed]
udp-fragmentation-offload: off
generic-segmentation-offload: on
generic-receive-offload: on
large-receive-offload: off [fixed]
rx-vlan-offload: off [fixed]
tx-vlan-offload: off [fixed]
ntuple-filters: off [fixed]
receive-hashing: off [fixed]
highdma: on
rx-vlan-filter: off [fixed]
vlan-challenged: off [fixed]
tx-lockless: on [fixed]
netns-local: off [fixed]
tx-gso-robust: off [fixed]
tx-fcoe-segmentation: off [fixed]
tx-gre-segmentation: off [fixed]
tx-gre-csum-segmentation: off [fixed]
tx-ipxip4-segmentation: off [fixed]
tx-ipxip6-segmentation: off [fixed]
tx-udp_tnl-segmentation: off [fixed]
tx-udp_tnl-csum-segmentation: off [fixed]
tx-gso-partial: off [fixed]
tx-sctp-segmentation: off [fixed]
tx-esp-segmentation: off [fixed]
tx-udp-segmentation: off [fixed]
fcoe-mtu: off [fixed]
tx-nocache-copy: off
loopback: off [fixed]
rx-fcs: off [fixed]
rx-all: off [fixed]
tx-vlan-stag-hw-insert: off [fixed]
rx-vlan-stag-hw-parse: off [fixed]
rx-vlan-stag-filter: off [fixed]
l2-fwd-offload: off [fixed]
hw-tc-offload: off [fixed]
esp-hw-offload: off [fixed]
esp-tx-csum-hw-offload: off [fixed]
rx-udp_tunnel-port-offload: off [fixed]
tls-hw-tx-offload: off [fixed]
tls-hw-rx-offload: off [fixed]
rx-gro-hw: off [fixed]
tls-hw-record: off [fixed]

 

0 Kudos
1 Reply

162 Views
yipingwang
NXP TechSupport
NXP TechSupport

The port fm1-mac9 is 10G Copper port, you need to use Cat6 Ethernet cable to connect to this port.

You could check whether FM1@TGEC1 can work under u-boot?

=> setenv ethact FM1@TGEC1

=> setenv ipaddr <ip_address>

=>ping <server_ip>

 

 

0 Kudos