EDAC register fail with fsl_mc_err_probe: No ECC DIMMs discovered with LSDK20.04 v4.19 kernel

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EDAC register fail with fsl_mc_err_probe: No ECC DIMMs discovered with LSDK20.04 v4.19 kernel

1,724 Views
hittzt
Contributor V

Hi experts,

When I test EDAC on nxp-ls1028ardb board with LSDK20.04 v4.19 kernel opening EDAC_DEBUG, the dmesg  shows followings:

root@localhost:~# uname -a
Linux localhost 4.19.90 #4 SMP PREEMPT Tue Jul 21 19:22:26 CST 2020 aarch64 aarch64 aarch64 GNU/Linux
root@localhost:~#

root@localhost:~# dmesg | grep EDAC
[ 1.768901] EDAC MC: Ver: 3.0.0
[ 1.772125] EDAC DEBUG: edac_mc_sysfs_init: device mc created
[ 3.658749] EDAC DEBUG: edac_mc_alloc: allocating 1928 bytes for mci data (4 ranks, 4 csrows/channels)
[ 3.663852] EDAC DEBUG: edac_mc_free:
root@localhost:~#
root@localhost:~# dmesg | grep ECC
[ 3.658776] fsl_mc_err_probe: No ECC DIMMs discovered
[ 9.880553] systemd[1]: systemd 237 running in system mode. (+PAM +AUDIT +SELINUX +IMA +APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ +LZ4 +SECCOMP +BLKID )
root@localhost:~#
root@localhost:~#

But I see the U-boot shows 


DRAM: 3.9 GiB
DDR 3.9 GiB (DDR4, 32-bit, CL=11, ECC on)

And the user manual of ls1028 board says that it supports ECC. 

So I want to query if there any known issue about ECC and EDAC?

Thanks,

Zhantao

0 Kudos
8 Replies

1,531 Views
yipingwang
NXP TechSupport
NXP TechSupport

Hello zhantao

The driver file drivers/edac/fsl_ddr_edac.c is not suitable for LS1028 platform, it's used for PowerPC platform.

Thanks,

Yiping

0 Kudos

1,531 Views
hittzt
Contributor V

Hi Yiping,

Thanks for your reply.

That is to say, all the arm64 processor based products like nxp LS-series do not support EDAC?

Thanks,

Zhantao

0 Kudos

1,531 Views
yipingwang
NXP TechSupport
NXP TechSupport

For Layerscape platform, please configure the following in Linux Kernel.

CONFIG_EDAC_DEBUG=y

CONFIG_EDAC_LAYERSCAPE=y

0 Kudos

1,531 Views
hittzt
Contributor V

Hi Yiping,

I have add all the following configs:

root@nxp-ls1028:~# zcat /proc/config.gz | grep EDAC
CONFIG_EDAC_SUPPORT=y
CONFIG_EDAC=y
CONFIG_EDAC_LEGACY_SYSFS=y
CONFIG_EDAC_DEBUG=y
CONFIG_EDAC_LAYERSCAPE=y

And the result is as what I stated.

Thanks,

Zhantao

0 Kudos

1,531 Views
yipingwang
NXP TechSupport
NXP TechSupport

Please configure ECC as the following in u-boot, then do EDAC verification. 

=> setenv hwconfig fsl_ddr:ecc=on

0 Kudos

1,531 Views
hittzt
Contributor V

Hi Yiping,

Thanks for your reply.

It seems even set hwconfig fsl_ddr:ecc=on in U-boot, the EDAC still not work.

Welcome to NXP LSDK 2004 main (GNU/Linux 4.19.90 aarch64)

* Support: https://www.nxp.com/lsdk
* Documentation: https://lsdk.github.io/document
* Licensing: https://lsdk.github.io/eula
root@localhost:~# dmesg | grep EDAC
[ 1.764898] EDAC MC: Ver: 3.0.0
[ 1.768120] EDAC DEBUG: edac_mc_sysfs_init: device mc created
[ 3.654712] EDAC DEBUG: edac_mc_alloc: allocating 1928 bytes for mci data (4 ranks, 4 csrows/channels)
[ 3.659814] EDAC DEBUG: edac_mc_free:
root@localhost:~#
root@localhost:~# dmesg | grep ECC
[ 3.654738] fsl_mc_err_probe: No ECC DIMMs discovered
[ 9.954633] systemd[1]: systemd 237 running in system mode. (+PAM +AUDIT +SELINUX +IMA +APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ +LZ4 +SECCOMP +BLKID )
root@localhost:~#
root@localhost:~# uname -a
Linux localhost 4.19.90 #4 SMP PREEMPT Tue Jul 21 19:22:26 CST 2020 aarch64 aarch64 aarch64 GNU/Linux
root@localhost:~#

Thanks,

Zhantao

0 Kudos

1,531 Views
yipingwang
NXP TechSupport
NXP TechSupport

Hello Zhantao,

I didn't reproduce this issue on LS1046ARDB and LS1088ARDB, this problem should be caused by EDAC driver not compatible with LS1028ARDB platform. I have reported this issue to the development team to do more investigation.

Thanks,

Yiping

0 Kudos

1,530 Views
hittzt
Contributor V

Hi Yiping,

Thanks a lot.
Please let me know if there is any progress.

Thanks,

Zhantao

0 Kudos