Porting OpenWrt/LEDE on QorIQ Layerscape ARMv8 Platforms

显示  仅  | 搜索替代 

Porting OpenWrt/LEDE on QorIQ Layerscape ARMv8 Platforms

Porting OpenWrt/LEDE on QorIQ Layerscape ARMv8 Platforms

OpenWrt is a highly extensible GNU/Linux distribution for embedded devices (typically wireless routers), OpenWrt is built from the ground up to be a full-featured, easily modifiable operating system for your router. LEDE is based on OpenWrt, targeting a wide range of wireless SOHO routers and non-network device. This document introduces how to porting and running OpenWrt/LEDE on QorIQ LS1012/LS1043 platform.

1. Porting OpenWrt/LEDE Source on QorIQ Layerscape Platforms

2. Deploy OpenWrt/LEDE Images to Boot up the System

3. Verify VLAN Interface and PFE in LEDE System

标签 (1)


I'm trying to create the image for LS1012ardb board from the OpenWRT/LEDE trunk.

I've cloned the OpenWRT/LEDE trunk:

git clone https://git.lede-project.org/source.git

and run:

./scripts/feeds update -a

./scripts/feeds install -a

and tried to configure with make menuconfig as is described in your document:

I've selected the NXP Layerscape, layerscape 64b boards and ls1012ardb-64b target profile. I've selected create a journaling filesystem and in firmware: rcw-layerscape-ls1012ardb.

But I can't see anything in the Boot loaders section of menuconfig to make the u-boot (but the source code is downloaded in dl directory).

I run make -j6 and ends without errors, but there is no bin files created in OpenWRT/bin directories:

missing PBL_0x35_0x08_800_250_1000_default.bin

missing u-boot-ls1012ardb.bin

missing ls1012ardb-ext4-firmware.bin

Applying patches to the trunk ends with error:

Patch failed!  Please fix /home/administrador/lede/target/linux/layerscape/patches-4.4/0002-layerscape-add-64b-32b-target-for-ls1012ardb-device.patch!

Have I missed something?




Anyone could help me?


I've got to decide if this is a suitable platform for our router design.

Thanks in advance.

Hello miguel lopez,

Sorry for not noticing your previous comment, I didn't follow in this page previously.

I remembered all NXP patches for LS1012/LS1043 had already be accepted by LEDE community. The latest version is v8, in this version, firmware rcw/uboot-32b/ppfe should be uploaded to github firstly.

The built flash image should include rcw/uboot/fman/ppfe/dtb/kernel/rfs, after program this flash image at address 0, the system can be set up.

I had already removed my LEDE workspace last year.

I need to clone the latest LEDE source code to do verification for you, will give you feedback later.



Hi  Yiping wang,

I am working on NXP board Model: LS1012A RDB Board, RevB. I am using yocto source LS1012A-SDK-SOURCE-20161230-yocto.iso.

I was able to flash and boot yocto kernel.itb and rootfs from SD card. But with the default yocto build images, Ethernet interface is not working.

So, I tried  openWrt by following steps as per "Porting Openwrt on QorIQ Layerscape ARMv8 Platforms.pdf" and facing the same issue as explained my miguel lopez.  No option to select under "Boot Loader", No .bin file generated after the build.

Need below clarification .. 

1. Do we need to apply the patch files which you attached above in your first post ? 

2. What are the the u-boot and kernel version used in this ? What are the kernel configuration to enable Ethernet interface on LS1012ARDB ?

3. How to generate uboot, kernel and other image file required to boot the LS1012ARDB board.

Hello srinivas reddy reddy,

I verified my document again some days ago, there was no problem.

1. No need to apply these patches, so far all these patches have already been accepted by LEDE community.

2. Kernel version should be 4.4, please refer to the Kernel configuration file in target/linux/layerscape/64b/config-default.

    U-BOOT version is 2016.09, u-boot is in the folder build_dir/target-aarch64_armv8-a_musl/uboot-layerscape-ls1012ardb/uboot-layerscape-v1.0.

3. You just need to use the final image bin/targets/layerscape/64b/lede-layerscape-64b-ls1012ardb-squashfs-firmware.bin.

Please pay attention to the following build procedure.

git clone https://github.com/lede-project/source.git

make menuconfig

Target System (NXP Layerscape)  --->

            (X) NXP Layerscape

Subtarget (layerscape 64b boards)  --->

            (X) layerscape 64b boards

            ( ) layerscape 32b boards

Target Profile (Default Profile)  --->

            ( ) Multiple devices

            (X) Default Profile

            ( ) ls1012ardb-64b

            ( ) ls1043ardb-64b

Global build settings  --->

            Binary stripping method (none)  --->

                        (X) none

                        ( ) strip

                        ( ) sstrip


[ ] Package the LEDE-based Toolchain

Boot Loaders  --->

            <*> uboot-layerscape-64b-ls1012ardb

            <*> uboot-layerscape-64b-ls1043ardb

Firmware  --->

            <*> fman-layerscape-ls1043ardb

            <*> ppfe-ls1012ardb

            <*> rcw-layerscape-ls1012ardb

            <*> rcw-layerscape-ls1043ardb



would you be so kind to point out what I would have to change in order to deploy openwrt on the Freedom reference board of the ls1012a?

Thanks in advance for any help,

‎11-23-2016 01:32 AM