LPCXpresso LPC1769 (OM13085) Can't find debug Probe

cancel
Showing results for 
Search instead for 
Did you mean: 

LPCXpresso LPC1769 (OM13085) Can't find debug Probe

2,398 Views
simonbertin
Contributor I

Hi,

I am using MCUXpresso IDE, I connected the board to my computer, using an USB cable.

But when I try to launch de debug session, the Probe discovery tool can't detect any device.

On the computer, I can find an MBED disk mounted.

I tried to install again the drivers, but noting changed.

We tried it on 2 different computers, and with 2 different boards, the result was always the same.

Did I miss something ?

Thanks.

6 Replies

591 Views
brendonslade
NXP Employee
NXP Employee

Until late 2017, LPCXpresso1769-CD boards produced were programmed with the mbed LPC11U35 debug probe. That year we introduced a new version of the firmware that was not based on mbed, and gave a simpler/cleaner installation process and better performance. You can find that firmware by searching for "lpc11u35 debug firmware" or directly at this link: https://www.nxp.com/webapp/sps/download/license.jsp?colCode=LPC11Uxx-Debug-Probe-VCOM&fsrch=1&sr=1&p...=

This package includes a driver for the VCOM function, plus the new debug probe firmware and instructions to install. Updating the firmware is easy - hold down reset while powering the board and you will see a device called CRP_DISABLD appear in your file manager. Delete the file there called firmware.bin, then drag and drop the file with the same name from the package you downloaded. Re-power the board and away you go!

To enable the VCOM functionality on this board you need to add a zero ohm resistor (or big blob of solder) to connect the TX and RX lines between the LPC1769 and debug probe. Refer to the schematic.

591 Views
danielholala
Contributor IV

Brendon Slade wrote:

...Updating the firmware is easy - hold down reset while powering the board and you will see a device called CRP_DISABLD appear in your file manager. Delete the file there called firmware.bin, then drag and drop the file with the same name from the package you downloaded. Re-power the board and away you go!

Hi Brendon,

Thanks for sharing these instructions.

Regarding holding down reset, I guess you don't mean to press the reset button (SW1) on the board as it is connected to RESET of the target processor LPC1769. I assume, you are rather suggesting to short the two pads at jumper 4 (JP4) to put LPC11U35 in ISP mode (according to schematic). At least that worked for me.

Now with the new firmware, the LPC1769 LPCXPRESSO CD behaves like to older board, i.e., that after re-powering the board the (not under control of debugger), the CPU automatically executed the progamm.

0 Kudos

591 Views
brendonslade
NXP Employee
NXP Employee

Hi Daniel,

Actually the debug probe on LPCXpresso-CD boards can be put into the DFU (firmware update) mode either by using the jumper or by using the reset button method. EA use a neat trick by routing the target reset to the pin on the LPC11U35 debug probe that causes that device to enter DFU mode, provided you are asserting it when you power up the board.

Anyway, glad you are up and running. We are working on documentation to help users of the LPCXpresso CD boards to make our user's life easier.

Best regards,

Brendon

0 Kudos

591 Views
simonbertin
Contributor I

Thanks for the advice,

After installing the MBED driver, the debug on MCUXpresso works.

0 Kudos

591 Views
lpcxpresso_supp
NXP Employee
NXP Employee

Did you install the MBED serial driver? See https://os.mbed.com/handbook/Windows-serial-configuration.

Thanks and regards,

MCUXpresso Support

591 Views
danielholala
Contributor IV

Hi,

Thanks, that helped.

But why would I need to download an MBED driver?

According to this page, the LPCXpresso board provides an USB debug interface that is CMSIS-DAP compatible and therefore I expected it to be supported by the  "MCUXpresso IDE LinkServer (inc. CMSIS-DAP)" probe as advertised "out-of-the-box". But when I want to connect MCUXpresso IDE (v10.1.1 [Build 606] [2018-01-02]) to the target, no compatible probes are found although this probe (and all others) are selected. Why is this?

0 Kudos