Change emualtor speed in "program flash".

cancel
Showing results for 
Search instead for 
Did you mean: 

Change emualtor speed in "program flash".

59 Views
lpcware
NXP Employee
NXP Employee
Content originally posted in LPCWare by matys4877 on Mon Sep 07 02:57:31 MST 2015
Hello.
I noticed that programming speed during "program flash" is over 5MHz. It's to much for me and 50% of attempt return error. I successfully changed wirespeed to 1MHz when debugging and it works well. I add -s 1000 to additional options in "program flash" dialog, but nothing has changed. I use home made cable for connection to my custom target. As emulator I use cmsis-dap from lpcxpresso54102. For local target on lpcexpresso board it works well but it seems that for my connection cable this speed is too much.

My system:
LPCXpresso v7.9.0 [Build 455] [2015-07-23]
Ni: LPCXpresso RedlinkMulti Driver v7.9 (Jul 23 2015 14:20:59 - crt_emu_cm_redlink build 468)
Pc: (  0) Reading remote configuration
Pc: (  5) Remote configuration complete
Nc: Probe Firmware: LPC-Link-II CMSIS-DAP (NXP)
Ubuntu 14.04

Best regards
Mateusz
0 Kudos
3 Replies

17 Views
lpcware
NXP Employee
NXP Employee
Content originally posted in LPCWare by matys4877 on Tue Sep 29 07:10:50 MST 2015
Hi.
I partially solved that issue. Problem was in usb hub. Probably after relatively long cable and hub the voltage was to low for lpc-link to work properly. Now I'm using active usb hub and it works much better.
Regards
Mateusz
0 Kudos

17 Views
lpcware
NXP Employee
NXP Employee
Content originally posted in LPCWare by matys4877 on Mon Sep 07 07:12:46 MST 2015
I changed it but it's still 4-5 MHz. I double check connections in first step and it seems ok. Problem may be in the length of cable. It's about 20cm. I attached screen-shot of settings and swclk signal.
Regards,
Mateusz
0 Kudos

17 Views
lpcware
NXP Employee
NXP Employee
Content originally posted in LPCWare by lpcxpresso-support on Mon Sep 07 05:36:18 MST 2015
Actually the default is typically 3 MHz. And I certainly wouldn't expect to see issues using this with LPC5410x parts. I would strongly suggest you check the integrity of your home made cable!

But that aside, changing the wirespeed for LPC-Link2/CMSIS-DAP connections is not done using the debug driver -s option. Rather it is a configuration within the "redlink server" executable. The simplest way to change it for IDE connections is to modify the workspace properties.

Window - Preferences - LPCXpresso - Redlink Options - Redlink wirespeed in Hz


Setting the value to 1000000 should give you 1 MHz connections.

Regards,
LPCXpresso Support
0 Kudos