The security certificate for downloading the LPC SDK Builder has expired and is no longer valid.

cancel
Showing results for 
Search instead for 
Did you mean: 

The security certificate for downloading the LPC SDK Builder has expired and is no longer valid.

431 Views
walkingthrough
Contributor II

Hello -

Wanted to download the LPC SDK Builder and both Firefox and Internet Explorer refuse with an indication that the security certificate expired Sunday, October 7.

Please fix.

Thank you.

Labels (1)
9 Replies

120 Views
tyler1
Contributor I

It has been a week since this question was posted but the certificate has not been updated. Is there any update from NXP on when this will be fixed? It is becoming a bottleneck and bypassing security settings is not an acceptable option. 

0 Kudos

120 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi Tyler Orr,

    Sorry for my later reply.

    I have been told that, the security certificate may be updated in the last Friday evening.

   Today, I have checked the MCUXpresso SDK website again, it works on my firefox now.

pastedImage_1.png

So, you can try it again on your side.

If you still have problems, please let me know.

Sorry for the inconvenience we bring you.


Have a great day,
Kerry

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

120 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi Mark Becker,

  Could you also give me some picture about your security certificate problem?

  Open https://mcuxpresso.nxp.com/en/welcome , then log on, if you meet problems, give me the screen shoot.

  Then I can help you to check it with our according department.


Have a great day,
Kerry

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

120 Views
walkingthrough
Contributor II

What Con Verse said.  :-)  As of 11:54 AM 10/10/2018 the certificate is still invalid.  And while Firefox 62.0.3 allows me to install an override, my local IT Department would probably pay me a visit.

There is a "getting started" sequence on NXP's site... and my boss put one of their Xpresso boards on my desk Monday.

I'd like to get started.

My boss would like me to get started, too.  :-)

Please fix.

Thank you.

0 Kudos

120 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi Mark,

   Check my the above reply, can you download the SDK now?

   This method is also shared by my IT department, just add the trust.

    If you use the xpresso board have the problems, welcome to create you own question post, we will help you in your post directly.

Wish it helps you!


Have a great day,
Kerry

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

120 Views
converse
Senior Contributor IV

Are you guys serious? A security certificate on one of your websites has expired and you want us to bypass security on our systems? This is a serious failing and makes me wonder whether I can trust NXP with anything.

This is what Firefox Says about the exception:

2018-10-11 09.07.33 am.png

Notice it says "Legitimate banks, stores and other public sites will not ask you to do this".

Please get your IT guys to renew the certificate ASAP. I (for one) will not be bypassing my companies IT policy, just because you cannot be bothered to keep your systems up to date.

120 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi Con Verse,

   Thanks for your updated information, we already report this problem to our IT department, this is already in the process. Bypass is just the temporary method to get the SDK. If you don't want to bypass it, it doesn't matter, but maybe you need to wait patiently.

   If they fix it, I will let you know ASAP, so now, please wait patiently.


Have a great day,
Kerry

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

120 Views
converse
Senior Contributor IV

The certificate has definitely expired.

this is what Safari reports, follow d by what the certificate shows. Suggest you ask your IT guys to fix this ASAP...

4AB1E1F4-281F-4C0F-ACCE-A4E426512FE8.jpeg

F272CB7F-CE54-446B-9B36-DFA7DA62EEA9.jpeg

0 Kudos

120 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi Con Verse,

    Thank you for your updated information.

    Please click"view the certificate", then add the https://mcuxpresso.nxp.com  as the security exception.

Please check the following picture from my side:

pastedImage_1.png

Then you can enter it.

pastedImage_3.png


Have a great day,
Kerry

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos