Hex file created but not working!

cancel
Showing results for 
Search instead for 
Did you mean: 

Hex file created but not working!

260 Views
Contributor III

Hello I am using Eclipse IDE for ARM development. I am using LPC1769  controller. I am able to build my project in eclipse , I don't get any errors and warnings after compiling the project. .hex file is also created. After flashing the program my pin doesn't toggle.I am using flash magic to flash the hex file. I tried the same code in Keil to check if there are hardware issues but it was working fine , the pin got toggled. I am completely stuck i don't understand what is the exact problem. If there were path related issues then I couldn't even build the code, it would have shown me errors regarding paths. But in this case i am not understanding how to solve this problem. Kindly help me!

Tags (3)
6 Replies

2 Views
Contributor III

Hello I select the hex file created and the device as shown below. (Note:In the screenshot , serial port is not selected because i have not connect the the target and my laptop) When connected i select the port and then click on start button.The program gets flashed but doesn't work. I am using USB to TTL for flashing.

pastedImage_1.png

0 Kudos

2 Views
Senior Contributor III

Have you set the vector checksum?

https://community.nxp.com/thread/389046 

The vector checksum is REQUIRED to be correct for your application to start. It is described in the LPC17xx User Manual.

2 Views
Contributor III

Hello @Con Verse ,

Thanks for your reply ,I had tried this project earlier also in eclipse itself,  at that time it was working perfectly without any errors, the GPIO got toggled. At that time i didn't set vector checksum still it was working. I don't  understand if i am doing the same thing again in eclipse , it should work. 

0 Kudos

2 Views
NXP TechSupport
NXP TechSupport

Hello Vishakha,

 

Could you compare the hex files to see if there is something different between what is Keil generating against the hex file that Eclipse generates?

 

Best regards,

Felipe

0 Kudos

2 Views
Contributor III

Hello @Felipe García , Thanks for your reply. Now I am working on MCUxpresso. I am able to do the same project in mcuxpresso. In MCUxpresso you just need to do settings for hex files and it works. Still couldn't find the solution for eclipse. I searched but couldn't find hex settings for Eclipse. Anyways, I have decided to use MCUxpresso now. 

Thanks

2 Views
NXP TechSupport
NXP TechSupport

Hi Vishakha,

 

Could you please provide the exact steps you are doing to flash the MCU using Flash Magic? I will try to reproduce this issue on my side.

 

Best regards,

Felipe