Problem with the uart of the board FRDM-K64F

cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with the uart of the board FRDM-K64F

Jump to solution
254 Views
Contributor II

Hi everyone!

 

I got a problem and I came here to ask if some of you might help me… I am using the board FRDM-K64F with the following software solutions:

KDS 3.2;

Processor Expert;

KSDK 1.3;

MQX provided by KSDK;

 

I am trying to develop an application to test one uart of the board, in the pins PTC14 and PTC15. The physical connections appeared to be fine, but there is something wrong with my software or my processor expert configuration, because when I run the code, nothing happens. The code follows annexed.

 

I hope you could help me.

Thank you.

Original Attachment has been moved to: testeUART.rar

Labels (1)
0 Kudos
1 Solution
11 Views
NXP TechSupport
NXP TechSupport

Hi Clecio:

Have you solved this issue? I tried your project after deleting the "\r\n", and found it still does not work. There is a bug on the function of "UART_DRV_IRQHandler", in file fsl_uart_driver.c.  the code will never move the position of TXbuffer and transfer byte numbers, so it lead to never to call UART_DRV_CompleteSendData.

please add the two read lines to the receive interrupt and send interrupt,

please check the below picture.

pastedImage_0.png

Your also can refer to the below thread.

The usage of UART callback function install 

Regards

Daniel

View solution in original post

0 Kudos
3 Replies
12 Views
NXP TechSupport
NXP TechSupport

Hi Clecio:

Have you solved this issue? I tried your project after deleting the "\r\n", and found it still does not work. There is a bug on the function of "UART_DRV_IRQHandler", in file fsl_uart_driver.c.  the code will never move the position of TXbuffer and transfer byte numbers, so it lead to never to call UART_DRV_CompleteSendData.

please add the two read lines to the receive interrupt and send interrupt,

please check the below picture.

pastedImage_0.png

Your also can refer to the below thread.

The usage of UART callback function install 

Regards

Daniel

View solution in original post

0 Kudos
11 Views
Contributor II

Hi Daniel.

 

Thank you for the help. As you said when I deleted the “\r\n” the project kept not working. Making the alteration from the picture you send, the project started to work, and I am very thankful for that. However, making a little research I found some topic in this forum where they found a similar bug, but in the rx buffer. Do you know if this information proceed?

Another question: Before you answer this post, I could not make the uart work so I decided to restart the project without using the processor expert. Then I found another problem (lucky me). When I use the Shell() function, the program exit, and I do not know more what to do… I created a new topic about this matter here:

https://community.nxp.com/message/828919

If you could just look at it and tell me if you know what is the problem I would really appreciate.

Thank you for your help was truly useful!

0 Kudos
11 Views
NXP TechSupport
NXP TechSupport

Hi Clecio:

I did a quick check of your code, in some cases, send buffer with '\r\n' maybe result in some unexpected errors, could you delete them and try it again?

...

void main_task(os_task_param_t task_init_data)
{
    uint8_t RxChar  = 0;
    uint8_t Buffer[] = "\r\n UARTTest\r\n";

...

Regards

Daniel

0 Kudos