KDS Connects to Board but KMS Doesn't

cancel
Showing results for 
Search instead for 
Did you mean: 

KDS Connects to Board but KMS Doesn't

549 Views
Contributor I

I have a FRDM-MC-LVPMSM Development Kit, and so far I have been able to upload the pmsm demo to it using Kinetis Development Studio, and spin a brushless dc motor. I am using Windows 7 64-bit. When I open the Kinetis Motor Suite, it is unable to find the board. The dialog pops up asking which port to use, and I select 'COM7' (the same port as OpenSDA in the Device Manager), but KMS tells me it 'Could not verify communication over port COM7.' I have tried restarting my computer and reinstalling KMS, but it still doesn't work.

Labels (1)
0 Kudos
2 Replies

8 Views
NXP Employee
NXP Employee

After downloading the project with KDS, the debugger is active and you must choose to resume execution in the debugger for the code to start working again.  If you simply terminate the debug connection you must hit the reset button to restart the code on the KV31 MCU. 

After you hit reset you should see the tri-color LED light up light blue and green.  If this light is not on then the code is not working properly.  Is there a chance that you secured the MCU or mass erased it? If so the board will no longer work with KMS.  You do need the latest version of the GDG service agent from P&E Micro installed within KDS.  you can get this by doing an update in KDS.

You also might have a difference in the elf file with KMS pointing at a different project than KDS.  If this is the case try loading the application .out file into the MCU with KMS.

0 Kudos

8 Views
Contributor I

Problem Solved. I was using KDS 3.2.0 instead of 3.0.0.

0 Kudos