Can't connect FRDM-KV31F with KMS

cancel
Showing results for 
Search instead for 
Did you mean: 

Can't connect FRDM-KV31F with KMS

780 Views
Contributor III

Hi.

I can't connect the FRDM-KV31F board with KMS.

At first, not CDC apears when I connect the board to PC.  Next I install the "MBEDWinSerial" and now I have a CDC port (In my case COM3).

Now I open KMS and I select the COM port, but its impossible connect with KMS.

 

Finding a solution I read in other post maybe is a problem with the FRMD-KV31F boards (KMS won't connect to kv31f board.).

How can I solve this problem ??

 

Thank's a lot.

Labels (1)
0 Kudos
5 Replies

41 Views
NXP Employee
NXP Employee

Hello Sergi,

Unfortunately there was an error in processing over 200 FRDM-KV31 resulting in the MBED OpenSDA being put on the board instead of the P&E bootloader and OpenSDA.

Have you read the document I wrote? https://community.nxp.com/docs/DOC-332745

If this workaround does not work for you I can fix your board.  I ask that you send it to me for repair. Let me know how you would like to handle this.

Regards,

Philip Drake

KMS Systems Engineer, NXP

0 Kudos

41 Views
Contributor III

Hi Philip.

I already saw the post that you comment, but I don't work for me.

I download the Segger_OpenSDA2.1.bin and put it in bootloader mode.

Now the CDC apears as "JLink CDC UART Port (COM6)" in System.

I open a KMS sample "sensorless" project  in KDS and I can able to debug using JLink debugger.

The FRDM board, now, show the red LED, and blue blinking LED.

If I connect the LVPMSM board to FRDM-KV31, the FRDM board show green LED and blue blinking.

But I still can't connect with KMS.

Alway get this error from KMS:

"Starting Processing
Loading a File from C:\Users\paloky\Documents\KMS_1.0.1\SavedProjects\FRDMKV31F_SNLESSVEL_KDS_1_0_1_211(1)\tools\..\KDS\Release\frdmkv31f_SNLESSVEL_KDS.elf
Target Board FRDM-KV31F not found.  Cannot download.
Processing Ended."

I using Windows 10, KDS 3.2 and KMS 1.0.1.211.

If I send you the board, you can fix.

Can you send me the post address to send you the board (I'm from Spain)?

Thank's a lot.

Sergi.

0 Kudos

41 Views
Contributor III

Finally, I have been able to solve the problem.

I read that there could be problems with KDS 3.2. Well, I have installed version 3.0.0 of the KDS.

With KMS 1.01, it was imposile to compile with KDS 3.0. I always got error on the Linker.

I uninstalled KMS 1.01 and installed KMS 1.0.0, and now I have been able to compile with KDS 3.0.

Once the FRDM-KV31 has been programmed with KDS 3.0, I was able to connect to the KMS 1.0.0.

There seems to be some problem with version 1.0.1 of KMS.

0 Kudos

41 Views
NXP Employee
NXP Employee

Make sure you update the P&E eclipse plug-in if you ever want to use it.

KMS 1.0.1 is only compatible with KDS 3.2 and will not work with KDS 3.0

KMS 1.0.0 is only compatible with KDS 3.0.1 with updates and does not work with KDS 3.2.

All of this is in the release notes and the getting started videos.

Glad you were able to use it after all.

Regards,

Philip

Philip Drake – Systems Engineer

Microcontrollers | NXP

Tel: +1 (512) 895 2044

Email: philip.drake@nxp.com<mailto:philip.drake@nxp.com>

www.nxp.com/kinetis/vseries<http://www.nxp.com/kinetis/vseries>;

0 Kudos

41 Views
Contributor III

I try using during all day KMS 1.0.1 and KDS 3.2, and I has been impossible to start the system.

Thank.

Sergi.

0 Kudos