Slow power up after NMI disable

cancel
Showing results for 
Search instead for 
Did you mean: 

Slow power up after NMI disable

Jump to solution
422 Views
mircopizzichini
Contributor III

Hi

Since I've to use NMI pin as GPIO, I disabled it writing 0xFB to address 0x0040 in flash configuration field. It works correctly, but the microcontroller power up is after about 4 seconds (both with and without j-link connected).

Now, if I try to revert my change (default was 0x3D), it never powers up!

How can I solve both situation?

Thank you

Mirco

0 Kudos
1 Solution
248 Views
jeremyzhou
NXP TechSupport
NXP TechSupport

Hi,

If the FOPT is configured as the 0xFB, then MCU will boot from the ROM, meanwhile it will be waiting for communication to begin on a peripheral until the detection times out, it needs some seconds.

So I think it's the root cause of the issue.
Have a great day,
Ping

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
4 Replies
248 Views
jeremyzhou
NXP TechSupport
NXP TechSupport

Hi Mirco,

It seems so weird, and I was wondering if you can tell me what chip you use, then I can replicate the issue on my site.

I'm looking forward to your reply.
Have a great day,
Ping

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos
248 Views
mircopizzichini
Contributor III

Hi Jeremy

I forgot to tell the chip... It's the KL03Z3VFK4, the same used on the FRDM-KL03Z.

I started with lptmr_example project: at first, with FOPT (in startup_MKL03Z4.S) at 0x3D, it started correctly... Then, since I wanted to disable NMI, I changed it to 0xFB, and that delay appeared.

If I go back to 0x3D, startup works correctly.

Let me know if you can replicate the issue, thank you.

Regards

Mirco

0 Kudos
249 Views
jeremyzhou
NXP TechSupport
NXP TechSupport

Hi,

If the FOPT is configured as the 0xFB, then MCU will boot from the ROM, meanwhile it will be waiting for communication to begin on a peripheral until the detection times out, it needs some seconds.

So I think it's the root cause of the issue.
Have a great day,
Ping

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos
248 Views
mircopizzichini
Contributor III

You're right, it's my fault!

I configure FOPT as 0x3B, disabling only NMI, and now it works properly.

Thank you

Mirco

0 Kudos