MK10DX Not Waking Up From LLWU Pin

cancel
Showing results for 
Search instead for 
Did you mean: 

MK10DX Not Waking Up From LLWU Pin

Jump to solution
447 Views
danebouchie
Contributor II

Hello,

I am trying to use a LLWU pin to wake up a MK10DX chip from LLS mode. I've successfully gotten the chip to to wake up from the LPTMR0, however, I can't seem to get a LLWU Pin to wake it up. I mainly use Processor Expert and have configured the LLWU pin settings in the CPU Component and added a Init_GPIO for Port D initializing the pin as an input with a pull-up resistor. I can therefore verify the following registers are being set: (We are using LLWU Pin 15 = PTD6)

LLWU_PE4 = 0xFF

LLWU_ME = 0x01

LLWU_RST = 0x02

PORTD_PCR6 = 0x103

GPIOD_PDOR = 0x00

GPIOD_PSOR = 0x00

GPIOD_PCOR = 0x00

GPIOD_PTOR = 0x00

GPIOD_PDIR = 0x00

GPIOD_PDDR= 0x00

From here, when I toggle LLWU Pin 15 (verified on Oscilloscope), it does not wake up the chip. So I don't know why this is not triggering a wake-up. Also, like I said, LPTMR0 works just fine, so it must be something to do with with how I'm configuring Port D, but after reading over the K10 Reference Manual and some forum questions/answers, the only requirement (from what I can tell) is that the LLWU Pin must be configured as a digital input like it is now. 

Any ideas to get this working, or ways to debug this further would be greatly appreciated,

Thanks.

Labels (1)
0 Kudos
1 Solution
256 Views
danebouchie
Contributor II

After testing with a new board, it began working. So ending up being a hardware problem.

Thanks again.

View solution in original post

0 Kudos
1 Reply
257 Views
danebouchie
Contributor II

After testing with a new board, it began working. So ending up being a hardware problem.

Thanks again.

View solution in original post

0 Kudos