Kinetis I2C ODE

cancel
Showing results for 
Search instead for 
Did you mean: 

Kinetis I2C ODE

603 Views
dieterteuchert
Contributor IV

Yesterday i implemented a test setup with a PCM1690 audio DAC, using KL10 I2C1 for control. When i looked at SDA with the scope, i found the ACK from the slave was at about 0.4 V. Though within specs, this looked ugly. I checked the pullup current and found the pullup resistor was about 150 Ohm. The error was in the I2C1 pin configuration. When i used the PORTx_PCRn configuration bit ODE (open drain enable) in addition to the pin MUX setting, everything looked perfect.

I am writing this note, because it's an error that may go unnoticed. I don't have time to check the Kinetis sample code, today i have to do the I2S part.

Labels (1)
Tags (3)
0 Kudos
2 Replies

104 Views
Paul_Tian
NXP Employee
NXP Employee

Hi, Dieter

I think you use K10 not KL10. If you use K series, you need to enable ODE bit when you use I2C module. Then you make these pins to be a open drain pin.

Hope my reply can help you.

Best Regards

Paul

0 Kudos

104 Views
dieterteuchert
Contributor IV

I did not want to start a discussion, but sorry, your reply was useless.

I reported unexpected behaviour when using I2C with a Kinetis processor (Totem-Pole SDA). It is not a problem nor an issue, just unexpected behaviour. While you may have been aware of this, you did not give any useful information which parts are affected. I think, my recommendation to use the ODE bit was valid and useful.

0 Kudos