Kinetis FlexNVM

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Kinetis FlexNVM

5,484 Views
hagguisouhail
Contributor III

Has any one succeeded to configure the memory linker to use the flexnvm as a pflash, i tried with the example in the mcuxpresso section 14.3 Configuring projects to span multiple Flash Devices  (Configuring projects to span multiple flash devices  ), however the program doesnt work and it runs into the hardfault routine. I will be kindly thankful for any help plz.

Pleaze find attached an example that i am working with.

Best regards,

29 Replies

695 Views
nsuresh2
Contributor III

Hi nxf46726,

Actually, do I need to follow step 1 and 2 if I am using only the KW36 micro (custom board), not the FRDM-KW36 board?

In my custom board, I don't have the OpenSDA programming option (programming through USB).

I tried step 3, 4 and 5 also. The data in the DFlash is not getting updated.

Do I need to make any changes in Project --> Properties --> C/C++ Build --> MCU Settings --> Memory details

Please find the below image.

I tried flashing the .axf file using JLink Flash V6.47a software, but it is not working.

Please check and let me know.

pastedImage_1.png

Thanks!

Regards,

Naven Suresh

0 Kudos

695 Views
EdgarLomeli
NXP Employee
NXP Employee

Hi Naven Suresh‌,

As you supposed, if you are using an external J-Link probe, you don't have to update the OpenSDA firmware.   

I forgot to mention that you have to install the J-Link Software. Go to your downloads folder and search the J-Link Windows installer (or your OS version). When customizing the installation, select the option below and remember the path (this is to ensure that you are using the correct J-Link version, a new folder will be created in your PC instead of only update the existing location with the new files).

pastedImage_1.png

Then, update the J-Link executable path in MCUXpresso IDE, using the destination folder created in the installation process. You only have to provide the new path for the JLinkGDBServerCL executable, there's no need to modify the other parameters in the J-Link Options window.

pastedImage_3.png

I'm sorry for the inconveniences.

Best regards.

695 Views
nsuresh2
Contributor III

Hi nxf46726,

Thanks for the update and support!

It seems like the issue is resolved. I could able to update the FlexNVM also.

Regards,

Naven Suresh

695 Views
miguel_reyes
NXP Employee
NXP Employee

nsuresh2@visteon.com‌, 

Could you please let us know what is your programming tool? what is the debugger you are using on your side?

Best regards,

Miguel 

0 Kudos

695 Views
nsuresh2
Contributor III

josem.reyes.chaidez‌,

Earlier before SEGGER v6.47a update, I used

IDE: MCUXpresso v10.3.1 (to compile) and IAR Embedded Workbench (to download the .axf or .s19 file to the HW which is generated using MCUXpresso)

Tool: SEGGER J Link Plus debugger

J Link version: v6.44

Now

IDE: 

1. MCUXpresso v11.0.0 (to compile and to download the .axf file to the HW)

2. IAR Embedded Workbench (to download the .axf or .s19 file to the HW which is generated using MCUXpresso)

3. J Link Flash v6.47a Software

Tool: SEGGER J Link Plus debugger

J Link version: v6.47a

Thanks!

Regards,

Naven Suresh

0 Kudos

695 Views
miguel_reyes
NXP Employee
NXP Employee

Hi Haggui, 

The responded that they will be providing updates next week about when they would be able to fix this. I will let you know as soon as I get a response on this. 

Thanks and best regards,

Miguel 

695 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi Haggui,

    You are referring to the wrong post, about the MCUXpresso IDE, when you want to define some data in the defined flash range, please refer to the following post:

Relocating Code and Data Using the MCUXpresso IDE 

   This is what you are needed, you need to modify the linker file.

Wish it helps you!

If you still have question about it, please kindly let me know.

Have a great day,
Kerry

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

695 Views
hagguisouhail
Contributor III

Hi Kerry,

Thank you for your quick response, maybe the thread I posted concerns the LPCXpresso IDE, however it contains the same steps as the thread you posted to me. The problem in fact came from the use of the FlexNVM as a PFlash. Thus when I add a section in the MCU setting that points to the FlexNVM region (@ 0x10000000 and LENGTH = 0x20000, alias Flash2), next using the cr_section_macros header file I define some data to be stored in this new region using __RODATA(Flash2). Everything seems to be OK until debugging, since i found that there is no data stored in the FlexNVM memory (it contains only 0xFFFFFFFF). My question, am I in need to specify a flash driver for the FlexNVM memory, as for the Pflash ? Moreover, am I in need to set the Flash Configuration block  ?

Thank you.

0 Kudos

695 Views
miguel_reyes
NXP Employee
NXP Employee

Dear Haggui Souhail

 

This is a known issue with MCUXpresso and projects using KW36. We will provide the fix in the public release of the KW35/36 device. 

 

Your technical support person will be contacting you directly to provide the patch and the steps to support this because product has not been launched yet.

 

Best regards,

Miguel