I have a KINETIS MOTOR SUITE, but when I plug in, LED in board will be light red. It is normal status or abnormal status?

cancel
Showing results for 
Search instead for 
Did you mean: 

I have a KINETIS MOTOR SUITE, but when I plug in, LED in board will be light red. It is normal status or abnormal status?

149 Views
bansondou
Contributor II

KINETIS MOTOR SUITE PROBLEMS. Could YOU PLEASE TELL ME HOW TO DO. OR TELL ME WHAT'S WRONG HAPPENED?

0 Kudos
1 Reply

43 Views
philip_drake
NXP Employee
NXP Employee

I will give you links below to help you along.

The how to do is shown in the Getting Started pages for KMS.  The other place to go is to the KMS UG

The Red LED indicates a fault.  Usually it means there is a reduced DC voltage than the KMS software in the KV31 or KV11 FRDM board.  Please refer to the UG and Lab Guide for useful information regarding KMS usage.

The first image that shows that the firmware is from a previous version is expected. Please proceed by following the directions given. Go to the Project tab and select Load Application Image. If this is the first use of the tool it will ask you for a path to the MCUXpresso or IAR installation.  Please supply the KMS GUI with that path and it will proceed with the generation of the .srec file using the tool and the download of the updated firmware to the KV MCU.  The download uses the Virtual MSD flash programming. 

Once that is completed re-connect with the MCU using the connect icon.png connect icon.

You can then start auto-measurement of your motor. 

Please go to thís link -- video vault and search for motor. There are a number of great videos on KMS and motor control.

For More information:

Best Regards,

Philip

0 Kudos