FRDM KW40Z "Fatal error:CPU did not power up"

cancel
Showing results for 
Search instead for 
Did you mean: 

FRDM KW40Z "Fatal error:CPU did not power up"

Jump to solution
3,052 Views
ramonramirez
Contributor II

I'm working with freedom KW40Z but when you load a sample project get me the following error  

CMSIS-DAP "Fatal error:CPU did not power up" ...

I am using iar 7.50 with an evaluation license for 30 days.

someone could help me

Best regards.

------------------------------------------------------------------------------

Tue Feb 09, 2016 13:05:30: Loaded macro file: C:\Program Files (x86)\IAR Systems\Embedded Workbench 7.3\arm\config\debugger\Freescale\KLxx.dmac

Tue Feb 09, 2016 13:05:30: Loading the CMSIS-DAP driver

Tue Feb 09, 2016 13:05:30: Probe: CMSIS-DAP probe SW module ver 1.11

Tue Feb 09, 2016 13:05:30: Probe: CMSIS-DAP S/N '0290ff039EF74E0B9E0BB363' mapped to a number 00363.

Tue Feb 09, 2016 13:05:30: EARM v.3.96

Tue Feb 09, 2016 13:05:30: Emulation layer version 3.96

Tue Feb 09, 2016 13:05:30: Notification to core-connect hookup.

Tue Feb 09, 2016 13:05:30: MDM-AP detected

Tue Feb 09, 2016 13:05:30: Probe: ConnectSpec='MBED CMSIS-DAP:0290ff039EF74E0B9E0BB363:8-1BB747AA-0-0000'.

Tue Feb 09, 2016 13:05:31: Connecting to TAP#0 DAP AHB-AP-CM port 0 (IDR=0x4770031).

Tue Feb 09, 2016 13:05:31: Recognized CPUID=0x410cc601 Cortex-M0+ r0p1 arch ARMv6-M

Tue Feb 09, 2016 13:05:31: Debug resources: 2 instruction comparators, 2 data watchpoints.

Tue Feb 09, 2016 13:05:31: CPU status OK

Tue Feb 09, 2016 13:05:31: LowLevelReset(hardware, delay 200)

Tue Feb 09, 2016 13:05:31: CPU status FAILED

Tue Feb 09, 2016 13:05:31: CMD_INTERPRETER: failed

Tue Feb 09, 2016 13:05:31: C:\Program Files (x86)\IAR Systems\Embedded Workbench 7.3\arm\config\debugger\Freescale\KLxx.dmac(82,17): Error: Operation error.

Tue Feb 09, 2016 13:05:31: Error while calling macro execUserCoreConnect

Tue Feb 09, 2016 13:05:31: CMD_INTERPRETER: failed

Tue Feb 09, 2016 13:05:31: C:\Program Files (x86)\IAR Systems\Embedded Workbench 7.3\arm\config\debugger\Freescale\KLxx.dmac(82,17): Error: Operation error.

Tue Feb 09, 2016 13:05:31: Error while calling macro execUserCoreConnect

Tue Feb 09, 2016 13:05:31: CMD_INTERPRETER: failed

Tue Feb 09, 2016 13:05:31: C:\Program Files (x86)\IAR Systems\Embedded Workbench 7.3\arm\config\debugger\Freescale\KLxx.dmac(82,17): Error: Operation error.

Tue Feb 09, 2016 13:05:31: Error while calling macro execUserCoreConnect

Tue Feb 09, 2016 13:05:31: CMD_INTERPRETER: failed

Tue Feb 09, 2016 13:05:31: C:\Program Files (x86)\IAR Systems\Embedded Workbench 7.3\arm\config\debugger\Freescale\KLxx.dmac(82,17): Error: Operation error.

Tue Feb 09, 2016 13:05:31: Error while calling macro execUserCoreConnect

Tue Feb 09, 2016 13:05:31: CMD_INTERPRETER: failed

Tue Feb 09, 2016 13:05:31: C:\Program Files (x86)\IAR Systems\Embedded Workbench 7.3\arm\config\debugger\Freescale\KLxx.dmac(82,17): Error: Operation error.

Tue Feb 09, 2016 13:05:31: Error while calling macro execUserCoreConnect

Tue Feb 09, 2016 13:05:32: CMD_INTERPRETER: failed

Tue Feb 09, 2016 13:05:32: C:\Program Files (x86)\IAR Systems\Embedded Workbench 7.3\arm\config\debugger\Freescale\KLxx.dmac(82,17): Error: Operation error.

Tue Feb 09, 2016 13:05:32: Error while calling macro execUserCoreConnect

Tue Feb 09, 2016 13:05:32: CMD_INTERPRETER: failed

Tue Feb 09, 2016 13:05:32: C:\Program Files (x86)\IAR Systems\Embedded Workbench 7.3\arm\config\debugger\Freescale\KLxx.dmac(82,17): Error: Operation error.

Tue Feb 09, 2016 13:05:32: Error while calling macro execUserCoreConnect

Tue Feb 09, 2016 13:05:32: CMD_INTERPRETER: failed

Tue Feb 09, 2016 13:05:32: C:\Program Files (x86)\IAR Systems\Embedded Workbench 7.3\arm\config\debugger\Freescale\KLxx.dmac(82,17): Error: Operation error.

Tue Feb 09, 2016 13:05:32: Error while calling macro execUserCoreConnect

Tue Feb 09, 2016 13:05:33: Fatal error: CPU did not power up   Session aborted!

Tue Feb 09, 2016 13:05:33: Loading the CMSIS-DAP driver

-------------------------------------------------------------------------------------------

attached a picture to the board with the configuration of jumpers

Labels (1)
Tags (2)
0 Kudos
1 Solution
377 Views
ramonramirez
Contributor II

Por fin encontré la solución a mi problema

En primera revisar que las conexiones en los  jumpers son las correctas para el tipo de alimentación en la que vamos a trabajar.

En segunda en el compilador iar forzar a un reset por software como se ve en la imagenCaptura.JPG

Después volví a descargar el programa y funciono!!!!

espero les funcione

saludos

View solution in original post

2 Replies
377 Views
franciscomezana
NXP Employee
NXP Employee

Thank you very much for your response Ramón.

I'd like to translate it for further reference in the future.

In IAR it is necessary to change the configuration, you just need to click in main menu on Project tab then follow Options... or Alt + F7:

pastedImage_1.png

You'll see the next window and you have to select as follows In Category < Debugger (CMSIS DAP) < Septup < Reset.

Then you have to select the option System (Default) then click OK.

pastedImage_2.png

You should download again and the problem should be fixed.

I hope this information helps.

0 Kudos
378 Views
ramonramirez
Contributor II

Por fin encontré la solución a mi problema

En primera revisar que las conexiones en los  jumpers son las correctas para el tipo de alimentación en la que vamos a trabajar.

En segunda en el compilador iar forzar a un reset por software como se ve en la imagenCaptura.JPG

Después volví a descargar el programa y funciono!!!!

espero les funcione

saludos

View solution in original post