in KDS2.0,  configurate "read-only" , while after debug ,it have no effect

cancel
Showing results for 
Search instead for 
Did you mean: 

in KDS2.0,  configurate "read-only" , while after debug ,it have no effect

Jump to solution
289 Views
Fan_xy
Contributor III

Hello,

 

I use KDS2.0, kl26z128vlh4 mcu, create a PE project , recofiguration the "Processor Expert.ld" file , build .debug, it can work well.

 

Then i save it to other place, then copy it under my kds workspace ,open it . build , while , when debug, the "Processor Expert.ld" file changed,

i'm sure i select the "read-only" configuration of the "Processor Expert.ld" file .

Please see the screenshot,  and tell me how should i do to enable the file do not changed .

 

before debug , it like this :

20274_20274.pngpastedImage_0.png

after debug , it like this :

 

 

I configurate the file to "read only" :

 

20279_20279.pngpastedImage_2.png

 

Thank you !

fan

Labels (1)
0 Kudos
1 Solution
134 Views
ZhangJennie
NXP TechSupport
NXP TechSupport

"read only" properties can't disable prm file be overwritten.

uncheck "generate linker file" for it.

disable prm generate.png


Have a great day,
Zhang Jun

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
3 Replies
134 Views
Fan_xy
Contributor III

after-debug.png

this is after debug screenshot .

0 Kudos
135 Views
ZhangJennie
NXP TechSupport
NXP TechSupport

"read only" properties can't disable prm file be overwritten.

uncheck "generate linker file" for it.

disable prm generate.png


Have a great day,
Zhang Jun

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos
134 Views
Fan_xy
Contributor III

Thank you !

0 Kudos