I don't want to use KDS SDK for KL03

cancel
Showing results for 
Search instead for 
Did you mean: 

I don't want to use KDS SDK for KL03

Jump to solution
326 Views
MarcoGiammarini
Contributor III

Hello!

For my projects, I and my team we use this library: ohilab/libohiboard · GitHub.

Now we want use KL03 and we want add support for this microcontroller into our library. So, I know that this library is ugly, but it is confortable for my team.

The question is: Can we don't use the KDS SDK for this microcontroller in our projects??

 

Thank

Marco

Labels (1)
Tags (3)
0 Kudos
1 Solution
90 Views
Jorge_Gonzalez
NXP Employee
NXP Employee

Hello Marco:

Do you mean creating a new bare project for KL03 without SDK?

If so, then yes I think this is possible. But to add support for KL03 you still need to install the KL03 KSDK update. To do this you have to download KSDK for FRDM-KL03Z from the next link:

Software Development Kit for Kinetis MCUs|Freescale

Install the package and then from KDS go to Help -> Install New Software -> Add. Browse to the location of the Eclipse update in the KL03 KSDK package.

With this the wizard will give you KL03 as an option.


Regards!,
Jorge Gonzalez

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

1 Reply
91 Views
Jorge_Gonzalez
NXP Employee
NXP Employee

Hello Marco:

Do you mean creating a new bare project for KL03 without SDK?

If so, then yes I think this is possible. But to add support for KL03 you still need to install the KL03 KSDK update. To do this you have to download KSDK for FRDM-KL03Z from the next link:

Software Development Kit for Kinetis MCUs|Freescale

Install the package and then from KDS go to Help -> Install New Software -> Add. Browse to the location of the Eclipse update in the KL03 KSDK package.

With this the wizard will give you KL03 as an option.


Regards!,
Jorge Gonzalez

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post