Can't install Kinetis Design Studio(KDS) on Ubuntu 16.04 64-bit

cancel
Showing results for 
Search instead for 
Did you mean: 

Can't install Kinetis Design Studio(KDS) on Ubuntu 16.04 64-bit

452 Views
Contributor III

Hello,

I want to install Kinetis Design Studio(KDS) IDE on Ubuntu 16.04 using the command given in section 2.3.2 of the link PDF_Link but i am getting error.i have attached screenshot of the error.the command which i have used is as below:

"$ sudo dpkg -i kinetis-design-studio_3.2.0-1_amd64.deb"

please help to install KDS on ubuntu 16.04.any help in this will be appreciated more.

Thank You

  Bhavin

0 Kudos
5 Replies

5 Views
NXP Employee
NXP Employee

Hello Bhavin,

Since KDS is in maintenance mode, is better to use MCUXpresso IDE as stated by Carlos.

Anyway, I have take a look on issue reported. According to attached screenshot found, that you are re-installing KDS on machine where was already installed once.

Linux DEB KDS installer has known bug, when is reinstalled over existing KDS installation on Linux Ubuntu.

In case you still need any work with KDS, you need to uninstall KDS first and then install again (also for any next re-installation on one machine).

to fix your problem run:

$ sudo dpkg -r kinetis-design-studio

when program is uninstalled run again installer by using

$ sudo dpkg -i kinetis-design-studio_3.2.0-1_amd64.deb‍‍‍‍

We are sorry for any inconveniences may have caused.

Best Regards,

Martin

0 Kudos

5 Views
Contributor III

Is there any update on this issue?

Its urgent for me any help in this will appreciate more.

0 Kudos

5 Views
NXP Employee
NXP Employee

Hi Bhavin,

If you are starting your development I would recommend you to look at MCUXpresso IDE rather than KDS IDE. This is actually a 64bit installation now (rather than 32bit as KDS was) - which makes it much each to get installed and running on 64bit version of Ubuntu.

Full installation instructions for MCUXpresso IDE can be found in the Installation Guide available from:

http://www.nxp.com/mcuxpresso/ide/documentation

Hope it helps!

Best Regards,
Carlos Mendoza
Technical Support Engineer

0 Kudos

5 Views
Senior Contributor III

I do not see any errors in you screenshot. What exactly is the error? Have you tried running the product? Does it run?

0 Kudos

5 Views
Contributor III

Hi Con Verse,

Thank you for your reply yes i am not getting any error but my installation is stopped after displaying warning message as displayed in my screenshot.and here below i attach other screenshot of this link PDF_Link. in this PDF it is mentioned to install 32 bit package for Ubuntu 1404 but for Ubuntu 16.04(64-bit) which package i have to install?

Screenshot from 2017-09-03 14-39-28.png

0 Kudos