BUG: KDS Update failure: Link fails for project working on another computer...

cancel
Showing results for 
Search instead for 
Did you mean: 

BUG: KDS Update failure: Link fails for project working on another computer...

410 Views
Senior Contributor I

Background: K64 project working fine on Win 8.1, but must deliver project on Windows 7. So, on Win 7, I:

  1. Installed KDS 3.2.0, applied all updates.
  2. Copied project files and added existing project to workspace.
  3. Build runs, compiles many dozens of files, no errors, all works as on Win 8.1 installation, except...
  4. Link fails with:
    arm-none-eabi-g++: error: unrecognized command line option '--defsym=__heap_size__=0x4000'

When I look at the project build settings for the linker, on Win 8.1 there is a listbox for adding linker flags:

176364_176364.pngpastedImage_3.png

On Windows 7 (the KDS install I just did), the Linker Flags listbox is missing!

176365_176365.pngpastedImage_4.png

KDS has incorrectly constructed the link line on Win7!

I've attached the correct (Win 8) and incorrect (Win 7) link line details

 

What is going on?
How can I get this project to work on Win7 ???

 

Thanks!
Best Regards, Dave

Original Attachment has been moved to: 20170215_build_failure.txt.zip

Original Attachment has been moved to: 20170215_build_Win8_AOK.txt.zip

Labels (1)
0 Kudos
8 Replies

16 Views
NXP Employee
NXP Employee

Hi Dave,

I think your problem is that you don't have the same plugins installed on the Win 8.1 and Win 7 machine.

That addtional Linker (-Xlinker) dialog element is not available in the plugin version which comes with the original 3.0.0 which is:
pastedImage_1.png

On the Win 8.1 machine you have installed updates:

>>Installed KDS 3.2.0, applied all updates.

With this, I assume you have installed a newer version (below is what I have which has that additional dialog added)

pastedImage_1.png

So if you want to have the project compatible that way, you have to have the same plugin versions.

Or specify the -Xlinker options in the 'Other linker flags' section:

pastedImage_2.png

I hope this helps,

Erich

0 Kudos

16 Views
Senior Contributor I

Hi Erich - Further information on update failure: apparently sourceforge changed to strong encryption and the updater distributed by Freescale/NXP cannot connect as of January. Astonishing that NXP/Freescale not aware of this?

Details and suggested fix here (see "Important Notes"):
How to install the GNU ARM Eclipse plug-ins?

I followed the instructions and updated the encryption tools, but I still get this update failure:

pastedImage_4.png

Any ideas how to get this sorted?

Thanks again,

Best Regards, Dave

0 Kudos

16 Views
NXP TechSupport
NXP TechSupport

Hello Dave,

You can use the offline mode to update :

First download the update file from  Releases · gnuarmeclipse/plug-ins · GitHub 

Then help-> Install New Software ->Add ...  find the zip file you have download .

Update ...

BR

Alice

0 Kudos

16 Views
Senior Contributor I

OK, I manually downloaded the GNU/GCC ARM tools zip, and manually installed from the ZIP.

Alice, have you reproduced this update error and filed a bug report?
I don't know if it is related to sourceforge changes in January or win7/32-bit.
Either way, KDS needs to have a working update!!

Thanks!
Best Regards, Dave

0 Kudos

16 Views
NXP Employee
NXP Employee

Hi Dave,

yes, this is related to the sourceforge changes in January (different encryption requried). And updating the Windows VM does not help as KDS is using its own local VM. There are currently no updates for KDS planned because of this. I know this might be painful, but later GNU ARM Eclipse updates are not required or can be installed manually if needed.

Thanks!

Erich

0 Kudos

16 Views
Senior Contributor I

Hi Eric - I did install the new Java encryption support, but still update does not work. In any case, KDS updates should work properly, even if Freescale/NXP needs to host included components where they can be accessed without strong encryption. And the updater should not fail silently, nor fail to explain which components were not updated!

Thanks!
Best Regards, Dave

PS: To be clear: I updated the Java copy contained within the KDS installation. The Win7 VM into which I installed KDS has no other Java installed.

0 Kudos

16 Views
Senior Contributor I

Hi Erich - The Win7 installation has an older version of the GNU ARM C/C++ Cross Compiler and friends. But, when I select this and click update, it churns for a while and says "no updates found". So, the problem is the update did not work.

Any idea why the update would not work?? I need to get this installation up to the latest version...

Thanks!
Best Regards, Dave

PS: Here's the Win7 installation, after updating everything (except it didn't do the update):

pastedImage_3.png

0 Kudos

16 Views
Senior Contributor I

Hi Erich - I "applied all updates" to both installations; they should be identical.
Thanks for providing the screenshot with the versions; I'll check this later.
Yes, I know I can move this setting from the listbox to the miscellaneous box, already done yesterday, but yikes...

Thanks again,
Best Regards, Dave

PS: Win 7 is 32-bit machine, don't know if that makes a difference.
Both installs from the same installation executable 3.2.0 so I'm puzzled why anything could be different...

0 Kudos