Detected 0 Channels. To operate PX4 you need at least 5 channels

cancel
Showing results for 
Search instead for 
Did you mean: 

Detected 0 Channels. To operate PX4 you need at least 5 channels

1,406 Views
Azer455
Contributor I

So, I bought the KIT-HGDRONEK66 recently.
Following the different steps, everything goes fine until the 'radio' section configuration in QGroundControl.

The software doesn't seem to detect any channels. I double-checked the setup, tried S-bus and I-bus configs, and made sure the RX is bound too.

This is for a project with a tight schedule so any help would be appreciated.

thanks for your time

 
 
 
 
0 Kudos
3 Replies

541 Views
acklyn
Contributor I

To operate PX4 you need at least 5 channels" PPM receivers that have an individual wire for each channel must connect to the RCIN channel via a PPM encoder like this one (PPM-Sum receivers use a single signal wire for all channels)

 

My Herbalife

0 Kudos

1,178 Views
PGB123
Contributor II

I had the same problem. I went into the Aux. Channels tab in settings on the transmitter and made sure to assign all of the channels. eg. Channel 5 - SwA  Channel6- SwB. I also made sure that the output mode was PPM, the serial was S.BUS, and the controller had the newest software version. (Found in GitBook) 

Hope it helps.

0 Kudos

1,247 Views
coryjfowler
Contributor I

For what is is worth, I am having the same SBUS related issue, but it is working with PPM.  I am not using the radio system in the HoverGames kit, but the system I am using has the ability to configure outputs as SBUS, PPM, etc.  I cannot get the FMUK66 to recognize the SBUS signal, but it works just fine with PPM.

0 Kudos