Recorder not working with MCSPTR2A5775E

cancel
Showing results for 
Search instead for 
Did you mean: 

Recorder not working with MCSPTR2A5775E

Jump to solution
212 Views
MarcoD
Contributor II

Hello,

I am working on the MCSPTR2A5775E kit. I solved an inital HW mistake I made, the motor is running and Freemaster is able to connect and I can see signals with the various screens.

However I now would like to use the recorder function, but that is not working ("Recorder could not be initialised. Error 0x80000094 (No resource instance at given index.)"). I have the original software and the latest Freemaster 3.1.1.

The properties of the recorder doesn't show any memory allocated for the recorder, do I need to change any default settings in order to be able to use it?

Recorder2.PNG

Recorder1.PNG

 

Thank you,

Marco

0 Kudos
1 Solution
112 Views
MichalH
NXP Employee
NXP Employee

Hello Marco,

I'm sorry I do not have the example code ready for this platform. However, I have reached out to owner of the solution internally in NXP and we were successful in replicating the Recorder issue that you are facing. 

I'm attaching a DLL as a patch to FreeMASTER 3.1.1. Please unzip and rename the new DLL over existing "c:\NXP\FreeMASTER 3.1\FreeMASTER\mcbc30.dll" (backup the original file just in case).

I will cooperate with the platform team to find the root cause of the issue (and to find out why other MCU platforms are not affected by it). The final fix will then be merged into next FreeMASTER release 3.1.2 by end of May.

Please let me know if you spot any issue after switching to the new DLL.

Thanks,
Michal

View solution in original post

4 Replies
145 Views
MichalH
NXP Employee
NXP Employee

Dear Marco,

this error code is returned by the FreeMASTER driver at MCU side when FreeMASTER tries to access a recorder instance which is not created or initialized. You are accessing the instance "0 (Default recorder)" so seems to me as you have FMSTR_USE_RECORDER set to 0 or if the recorder is not initialized. Make sure the FMSTR_USE_RECORDER is set to 1 at least.

The recorder #0 is initialized automatically if FMSTR_REC_BUFF_SIZE is set. So, either make sure this parameter is set in freemaster_cfg.h file to a reasonable memory amount (e.g. 1024). OR leave it undefined and call FMSTR_RecorderCreate() somewhere in your initialization code (refer to example application for more details).

Is it possible for you to run a bare freemaster example application on this board to rule out other issues that might occur (e.g. that the application corrupts the memory after the recorder is initialized etc.)?

Regards,
Michal

 

0 Kudos
136 Views
MarcoD
Contributor II

Hi Michal,

I am running the code out of the box for this dev-kit. During my experiments of clearing and re-importing the source files, I was able to have the recorder running; however, after closing and re-opening FreeMaster, it stopped working again.

Do you have a sample project I can flash on this board to try the test you are suggesting?

 

Best Regards,

Marco

0 Kudos
113 Views
MichalH
NXP Employee
NXP Employee

Hello Marco,

I'm sorry I do not have the example code ready for this platform. However, I have reached out to owner of the solution internally in NXP and we were successful in replicating the Recorder issue that you are facing. 

I'm attaching a DLL as a patch to FreeMASTER 3.1.1. Please unzip and rename the new DLL over existing "c:\NXP\FreeMASTER 3.1\FreeMASTER\mcbc30.dll" (backup the original file just in case).

I will cooperate with the platform team to find the root cause of the issue (and to find out why other MCU platforms are not affected by it). The final fix will then be merged into next FreeMASTER release 3.1.2 by end of May.

Please let me know if you spot any issue after switching to the new DLL.

Thanks,
Michal

View solution in original post

95 Views
MarcoD
Contributor II

Hi Michal,

thank you, with the new dll it is working!

 

I will be in touch if I will have issues n the future; for now I am happy!

 

 

Best Regards,

Marco

0 Kudos