Backward compatibility of FreeMaster 3.1

cancel
Showing results for 
Search instead for 
Did you mean: 

Backward compatibility of FreeMaster 3.1

Jump to solution
217 Views
nxf63246
NXP Employee
NXP Employee

I was working on a project with Freemaster 3.0 then I updated it to the version 3.1. I modified a few things and now if I try to open the project with the FreeMaster 3.0 it says "Unexpected file format".

Screenshot 2021-01-28 094016.png

 Of course the file format is the same as before.

Screenshot 2021-01-28 094202.png

 Is this an expected behavior or is something wrong on my side?

0 Kudos
1 Solution
200 Views
MichalH
NXP Employee
NXP Employee

Hello,

the PMP binary format is changed with each release of FreeMASTER tool. The FreeMASTER tool is backward compatible so any new version is able to open PMP files created in older versions, but not vice versa.

the PMPX (XML) format is both backward and forward compatible, so you should be able to save your work as PMPX in 3.1 and open it back in 3.0. Of course, there new features like global enumeration types, virtual variables etc. will not be imported properly in 3.0. But general objects like variables and views should be imported well. 

Let me know if you face any issues.

Regards,
Michal

View solution in original post

1 Reply
201 Views
MichalH
NXP Employee
NXP Employee

Hello,

the PMP binary format is changed with each release of FreeMASTER tool. The FreeMASTER tool is backward compatible so any new version is able to open PMP files created in older versions, but not vice versa.

the PMPX (XML) format is both backward and forward compatible, so you should be able to save your work as PMPX in 3.1 and open it back in 3.0. Of course, there new features like global enumeration types, virtual variables etc. will not be imported properly in 3.0. But general objects like variables and views should be imported well. 

Let me know if you face any issues.

Regards,
Michal

View solution in original post