LTIB build problem at package pkgconfig for Freescale M54418

显示  仅  | 搜索替代 

LTIB build problem at package pkgconfig for Freescale M54418

970 次查看
Contributor III


Ltib build is failing at package pkgconfig,




checking for a BSD-compatible install... /usr/bin/install -c

checking for extra flags to get ANSI library prototypes... configure: error: cannot run test program while cross compiling

See `config.log' for more details.

configure: error: /bin/bash './configure' failed for glib-1.2.8

error: Bad exit status from /home/fbouchard/ltib/ltib-modelo-20100709/tmp/rpm-tmp.91454 (%build)



RPM build errors:

    Bad exit status from /home/fbouchard/ltib/ltib-modelo-20100709/tmp/rpm-tmp.91454 (%build)

Build time for pkgconfig: 14 seconds


Failed building pkgconfig



f_buildrpms() returned an error, exiting





Started: Fri Mar 22 16:58:16 2013

Ended:   Fri Mar 22 16:59:16 2013

Elapsed: 60 seconds


These packages failed to build:



Build Failed


Exiting on error or interrupt



Now in a post I saw if I understand correctly, this package isn't meant for the Coldfire processors




Enrico> The bundled glib-1.2.10 is not crosscompile'able.


Enrico> Look at glib-1.2.10/ once you use AC_TRY_RUN, your

Enrico> package cannot crosscompile. A very common standard error in

Enrico> autoconf-based packages ...


But if you build with an external libglib (--with-installed-glib) it

builds without problems.


- tried in pkconfig.spec (made backup of the original)



I tried the trick above but it didn't work.



Any hints on how to compile pkgconfig?




标签 (1)
0 项奖励
1 回复

460 次查看
Contributor III

I found the error.

Somehow the temporary script is not going into the right directory.

See in bold:

Processing: pkgconfig



Building for target m68k

Executing(%build): /bin/sh -e /home/fbouchard/ltib/ltib-modelo-20100709/tmp/rpm-tmp.12682

+ umask 022

+ cd /home/fbouchard/ltib/ltib-modelo-20100709/rpm/BUILD

+ ./configure --prefix=/usr --host=m68k-linux --with-internal-glib

/home/fbouchard/ltib/ltib-modelo-20100709/tmp/rpm-tmp.12682: 1: ./configure: not found

error: Bad exit status from /home/fbouchard/ltib/ltib-modelo-20100709/tmp/rpm-tmp.12682 (%build)

Instead it should go to here : /home/fbouchard/ltib/ltib-modelo-20100709/rpm/BUILD/pkg-config-0.28, but I don't know what to modify.  Would it be the specfile?

0 项奖励