I can not connect my LS1012A target board with CodeWarrior TAP(code warrior 11.2.3).

cancel
Showing results for 
Search instead for 
Did you mean: 

I can not connect my LS1012A target board with CodeWarrior TAP(code warrior 11.2.3).

876 Views
toshiyukimaekaw
Contributor II

Hello,

I got CodeWarrior TAP(CWH-CTP-BASE-HE) and CWH-CTP-CTX10-YE and connected to the JTAG port of my LS1012A target board.
But CodeWarrior couldn't find LS1012A.

This is Information about situation.
- We connected Host computer to CodeWarrior TAP by USB cable. (No connect Ethernet cable)
- TX/RX LED blinking green. (during connect to LS1012A, LED blink red.)
- after target board power on, RUN/PAUSE LED is red.
- Connection Diagnostics of CodeWarrior says "no user-defined tests found".

- Number of Soc is LS1012ASN7HKA.
- Core and Platform voltage     : 0.9V is OK
- PLL supply voltage            : 1.8V is OK
- Oscillator PLL supply voltage : 1.35V is OK
- SerDes PLL supply voltage     : 1.35V is OK
- O1VDD, O2VDD voltage          : 1.8V is OK
- EVDD voltage                  : 3.3V is OK
- DDR3L DRAM I/O voltage        : 1.35V is OK
- XTAL IO and osc supply voltage: 1.8V is OK
- XOSC PLLvoltage               : 0.9V is OK
- Power Supply up sequence is within recommended.
- Input clock is 25MHz square wave to EXTAL pin.
- PBL load from 2bit QSPI Flash ROM. (Now QSPI is blank.)
      cfg_eng_use(UART1_SOUT)       : pullup 4.7kohm to 1.8V
      cfg_eng_use2(QSPI_A_DATA0)    : pullup 4.7kohm to 1.8V
      cfg_func_backup(QSPI_A_DATA1) : pulldown 4.7kohm to GND
      cfg_sysclk_sel(QSPI_A_CS0)    : pulldown 4.7kohm to GND
- After PORESET_B is nagated, LS1012A start to read PBL from 2bit-QSPI. (QSPI_A_SCK is clocking)
      PORESET_B continues to be asserted for 240ms after the start of all power supplies.


When observing the signal of the JTAG port with an oscilloscope, the state of each signal is as follows.
- TMS  : change "H" and "L"
- TDI  : change "H" and "L"
- TCK  : 20kHz clocking during connect
- TDO  : stable "L"
- TRST : stable "H"

I really need your help.

Labels (1)
0 Kudos
4 Replies

291 Views
toshiyukimaekaw
Contributor II

Hello Yiping Wang,

Thank you very much for your prompt reply.

We confirm with that plan according to your advice.
We'll contact you as soon as we finish confirming.

Thank you for your time and consideration.

Best Regards,
Toshiyuki Maekawa, Advanet Inc.

0 Kudos

293 Views
toshiyukimaekaw
Contributor II

Hello Yiping Wang,

We solved this problem on our own.

Table 1 of the Datasheet of LS1012A has the following description in the Note of Pinout list by bus.
  23. In external clock oscillator mode, cfg_eng_use and Cfg_eng_use 2 power-on-reset configuration pins should be pulled high.

In accordance with this description, we added a pull-up resistor.
However, when the pull-up resistor was removed, CodeWarrior found LS1012A.

I appreciate your support in kind and respectful manner.

Best Regards,
Toshiyuki Maekawa, Advanet Inc.

0 Kudos

291 Views
yipingwang
NXP TechSupport
NXP TechSupport

Hello Toshiyuki Maekawa,

First please let us check the basic CodeWarrior configuration.

On the LS1012A custom board, there should be no valid RCW on QSPI flash, please use hard-coded RCW enabled from CodeWarrior IDE. Please modify the variable “useSafeRCW” as True in the target Initialization file.

Please refer to the following

# Uncomment to enable RCW override
useSafeRCW = True
Reset(useSafeRCW)

In addition, it seems that there is problem with the basic configuration, you are using CodeWarrior TAP USB connection, however it seems that CodeWarrior TAP Ethernet connection is used according to the attached checking information.

You could refer to the section "1. CodeWarrior Connects to the Bare Board to do Flash Programing" in the document Use CodeWarrior for ARMv8 to Debug U-boot and Linux Kernel and Bring up Bare Boards to configure the debugger launch configuration.

Please note, in Target Configuration panel please configure CodeWarrior TAP Connection as "USB".


Have a great day,
TIC

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

293 Views
shyam_baldha
Contributor I

Hello Yiping,

Where should I find target initialization file to update "useSafeRCW" vairable?

Thanks,

Shyam

0 Kudos