After I run dbug, i can not go back uClinux even I plug the JP3 on(M5208)

cancel
Showing results for 
Search instead for 
Did you mean: 

After I run dbug, i can not go back uClinux even I plug the JP3 on(M5208)

1,688 Views
chenjuan
Contributor I
Hi, I got a serious problem.
I ran a demo : DemoDIO under the dBUG mode, then reset everything(software/ hardware). after I plug in the JP3(JP3 on), then I can not go back to use uClinux. when I turn on the board the tout0 does not light up any more and SBCtool keep go into dbug mode. why? and how can I change it back. 
 
please help me! thanks a lot.
Labels (1)
0 Kudos
2 Replies

226 Views
TTerho
Contributor I
Sounds like you are having the flash erased and uClinux replaced by the dBUG firmware. If you have P&E's BDM device with your EVB, you should be able to restore uClinux with CFFlasher program. I have used this method to restored uClinux after flash erased.
 
Hope this helps you.
0 Kudos

226 Views
TTerho
Contributor I
In addition to the previous: I just realized this is a Codewarrior forum (entered here from a Google entry). My problem was actually the same, Codewarrior replaces any programs on the flash memory; so my solution should help you. The CFFlasher programmer I mentioned is provided with the EVB on SBCTools CD, also it's available here on this freescale.com site. And when you are using M5208, remember to upgrade the tool to supply this processor (upgrade is available separately).
 
If you haven't bought the Codewarrior yet, and you are going to develop software to uClinux, I recommend you to use the SBCTools environment instead of Codewarrior, just because it's free.
0 Kudos