issue with Codewarior 10.3 "mingw32-make: *** Access denied."

cancel
Showing results for 
Search instead for 
Did you mean: 

issue with Codewarior 10.3 "mingw32-make: *** Access denied."

3,764 Views
Contributor II

Hi all,

 

I have an issue with Codewarior 10.3 during project compilation, even after a new installation:

 

"mingw32-make: *** Waiting for unfinished jobs...."

"mingw32-make: *** Access denied."

 

My configuration:

- AMD64

- Windows 7 64

 

I did not find solution on the forum... Has anybody a solution? Thank you.

 

C.B.

Labels (1)
28 Replies

112 Views
Contributor II

Has this issue ever been fixed?  I have the same problem with Kinetis Design Studio.  We have Kaspersky Endpoint Security 10.2.1.23.

0 Kudos

112 Views
NXP TechSupport
NXP TechSupport

This is a SW files conflict issue. I don't think it is removed.

0 Kudos

114 Views
Contributor II

Hello ecb,

I am experimenting the same problem. My project was working fine yesterday, but today I tried to compile and that error has appeared, I don't know what is happening...

"mingw32-make: *** Access denied."





0 Kudos

114 Views
NXP Employee
NXP Employee

Do you have CygWin installed (typically it is in C:\Cygwin folder)?

If so, can you rename that folder so Cygwin make is not found and see if this fixes your problem?

0 Kudos

114 Views
Contributor II

Hi Erich,

I don't have Cygwin installed.

I created a new project using processor expert and this is the complete trace.

**** Build of configuration MCF51QM128_Internal_Flash for project Test1 ****

C:\Freescale\CW MCU v10.2\gnu\bin\mingw32-make -j8 all

'Building file: ../Sources/Events.c'

'Building file: ../Sources/ProcessorExpert.c'

'Building file: ../Project_Settings/Startup_Code/startcf.c'

'Building file: ../Generated_Code/Cpu.c'

'Building file: ../Generated_Code/DMA1.c'

'Building file: ../Generated_Code/DMAT1.c'

'Building file: ../Generated_Code/PE_LDD.c'

'Building file: ../Generated_Code/Vectors.c'

'Executing target #1 ../Sources/Events.c'

'Executing target #2 ../Sources/ProcessorExpert.c'

'Executing target #3 ../Project_Settings/Startup_Code/startcf.c'

'Executing target #4 ../Generated_Code/Cpu.c'

'Executing target #5 ../Generated_Code/DMA1.c'

'Executing target #6 ../Generated_Code/DMAT1.c'

'Executing target #7 ../Generated_Code/PE_LDD.c'

'Executing target #8 ../Generated_Code/Vectors.c'

mingw32-make: *** Access denied.

.  Stop.

mingw32-make: *** Waiting for unfinished jobs....

mingw32-make: *** Access denied.

.  Stop.

0 Kudos

114 Views
NXP Employee
NXP Employee

I still belive this is something with the Windows permissions.

The make utility needs some temporary batch files, so it could be that creation of this is denied:

mingw - CMake fails to compile simple test, error 5 Access denied - Stack Overflow

0 Kudos

114 Views
Contributor III

Erich,

Thank you for posting this response!

I encountered a similar problem compiling examples for the FRDM KE02Z and the question I posted linked me to your suggestion. It allowed me to compile but I am curious if you could explain the long term fix? I cannot disable anti-virus every time I need to compile.

Thanks again,

Yusif Nurizade

0 Kudos

114 Views
NXP Employee
NXP Employee

Hi Yusif,

is the problem with your firewall/virus scanner? Then this is really a problem of a bad (free of charge?) virus scanner. I don't ask you not to use a virus scanner, but use one which is better and correclty handles virus threads. Which one are you using? I'm using McAffee and Norton and never had problems. So it indeed could be with the software you are using.

What could help is that you submit your problem to the vendor of your virus scanner so they could fix it?

I hope this helps.

0 Kudos

114 Views
Contributor III

Erich,

Thank you for the quick reply. I imagine the problem is with the anti-virus due to the suggestion/explanation I found here (linked to StackOverflow) and the fact that I was able to compile when applying this fix. I use Kaspersky which is a paid and fairly well recognized anti-virus that I'm otherwise very happy with.

The term for the anti-virus subscription expires this month so I will address the issue with the vendor and decide whether or not to renew depending on what they say.

Thanks again for the help!

Yusif

0 Kudos

114 Views
Contributor II

Hello all,

I have the same problem when my antivirus (Kaspersky 2013) is running. I have added mingw32-make as an exception for the antivirus, but still does not work. The only way is to close the antivirus before compiling. Any new ideas? Is this going to be fixed?

Best regards

Marcos

0 Kudos

112 Views
Contributor III

Hey Marcos,

I am working with Kaspersky as well and originally put up this discussion:

https://community.freescale.com/thread/314439


Since turning off Kaspersky is not a long term solution, I've contacted the company and have been led through a bunch of steps by the support staff. So far nothing has done the trick and since I was able to compile my own projects (not downloaded samples) I put the issue on the back burner. Yesterday, however, I started getting the error again with a project that I created from scratch (albeit sporadically) so I am again focused on resolving it. The latest email from support was a rather long set of steps which I will try tomorrow and report back as soon as I am able.


Best,

Yusif

0 Kudos

112 Views
Contributor II

I had the same issue with Kaspersky Endpoint Security Version10.2.1.23. Excluding all applications in the CW 10.5 path solved the issue.

0 Kudos

112 Views
Contributor II

Hi Yusif,

thanks for your comments. I look forward for your posts :smileyhappy:

BR,

Marcos

0 Kudos

112 Views
Contributor III

Hey Marcos,

Sorry I didn't update for a while. I've been swamped with work.

Are you having this problem with sample code you got offline or projects you made from scratch yourself? The latter has been working fine for me for some time.

Let me know,
Yusif

0 Kudos

112 Views
Contributor II

Hi Yusuf,

it happens to me with a project we made from scratch. At the beggining (more than one year ago) it worked properly but some months ago it started failing. I cannot tell if some significant change was done in the computer.

BR

Marcos

0 Kudos

112 Views
Contributor I

I had the same problem and the source eventually was discovered to be my anti-virus software.  For some reason Windows did not close the file properly and when the tools tried to recreate make files during build, my AV software blocked it.  Turn off the AV software long enough to retry.

Best Regards,

Drew

0 Kudos

114 Views
NXP Employee
NXP Employee

Hi Marcos,

>>"Is this going to be fixed?"

I would say this is a question to Kapersky?

Best regards,

Erich

0 Kudos

114 Views
Contributor II

Hey Erich,

yes, this is probably a question for them, but I think Freescale should contact Kaspersky to solve the issue. I'm sure you (Freescale - wow!) can get a faster and better response than me (Marcos who?). Furthermore, you know how your applications are working, so I guess the solution is easier if you cooperate.

Thanks for your help.

Marcos

0 Kudos

114 Views
NXP Employee
NXP Employee

Hi Marcus,

let's hope that this is the case. I'll have them contacted.

0 Kudos

112 Views
Contributor II

Thanks a lot Erich.

BR

MArcos

0 Kudos