Warnings about macros in project settings - how to improve?

cancel
Showing results for 
Search instead for 
Did you mean: 

Warnings about macros in project settings - how to improve?

Jump to solution
438 Views
Specialist V

Hi All

 

When moving projects created with CW10.2 to CW10.5 there are a warning when importing:


"References to the ${workspace_loc:<resource>} macro were found in the project settings. Using this macro could cause unexpected errors when the resource is not open or available in the workspace. Using the ${ProjDirPath} macro is preferable."

- followed by a list of project or target references.

 

I wanted to clean up the project so that these warning are no longer shown (otherwise other users of the projects report that there must be a problem with them) but couldn't find any such macros used in path variables or elsewhere.

 

Does anyone know what can be done to adjust a project accordingly?

 

Regards

 

Mark

Labels (1)
Tags (1)
1 Solution
78 Views
NXP Employee
NXP Employee

Hi Mark,

I would check the compiler settings (include search paths, etc) where these kind of macros might be used.

Otherwise: open the .project and .cproject files in a text editor and search for that macro: then either change it in the file directly, or this gives you a hint where in the settings that macro is used.

I hope this helps.

View solution in original post

3 Replies
78 Views
NXP Employee
NXP Employee

Hello Mark:

Did you look at the include directories?

Go to Project -> Properties -> C/C++ General -> Paths and Symbols, and verify that none of the include directories for assembly or C languages is pointing to the workspace.

Regards!

Jorge Gonzalez

79 Views
NXP Employee
NXP Employee

Hi Mark,

I would check the compiler settings (include search paths, etc) where these kind of macros might be used.

Otherwise: open the .project and .cproject files in a text editor and search for that macro: then either change it in the file directly, or this gives you a hint where in the settings that macro is used.

I hope this helps.

View solution in original post

78 Views
Specialist V

Hi Eric

Thanks - it was indeed in the compiler include path.

In each project I modified the include path from

"${workspace_loc:/Project/Applications/Target}"

to

"${ProjDirPath}/Applications/Target"

and then CW was happy again.

Regards

Mark