Rebuild EWL for Coldfire V1+

cancel
Showing results for 
Search instead for 
Did you mean: 

Rebuild EWL for Coldfire V1+

Jump to solution
593 Views
chbecker
Contributor II

Hello everybody,

 

currently I`ve trying to rebuild the standard EWL libraries.

 

The reason was, I've got Compiler Warnings as they`re described in

https://community.freescale.com/thread/300543

 

Source file >"D:\workspace\ColdFire\ColdFire_Build_Tools\ewl\EWL_Runtime\..." not found, cannot display source

 

So I've tried as suggested:

 

  • Import project located in {Install}\MCU\ColdFire_Support\ewl in CodeWarrior
  • Click right on the project name then select Build Configuration > Set Active and select the appropriate configuration. This depend on the run time library file you are linking with your application.
  • Build the project to create a new .a file. All the debug information will then point to your current installation directory and you should be able to link your application

 

with Build Configuration "CF_EWL_C" I could build without errors, and also the warnings for the EWL C Library disappears in my project.

 

But any other Build Configuration failed, Ive tried "CF_EWL_RUNTIME" (because had 4 warnings referenced to it) but build failed with 3 Errors:


make: *** [all] Error 2    coldfire_lib             C/C++ Problem

make[1]: *** [v1/librt] Error 2

make[2]: *** [Runtime_CF_CmdLineData/v1/librt/obj/MWException.o] Error 1

 

Does anyone have a solution to build the EWL library project successfully?

 

I've testedd with Codewarrior for MCU V10.4 and V10.2, same results.

 

Best regards,

 

Christian

Labels (1)
1 Solution
256 Views
mwais
Contributor II

Take a look at this thread: Odd / Irrelevant Linker Warnings in CW v10.4

I was able to import the coldfire_lib located at C:\Freescale\CW MCU v10.4\MCU\ColdFire_Support\ewl

locate coldfire_lib project to import into CW 10.4

pastedImage_1.png

Once imported, select Build configuration and  a large menu like the one below is displayed.  Select the appropriate build configuration and do a clean and build. See sequence below

pastedImage_2.png

I cleaned and rebuilt these configurations in this order:

1) ALL the EWL_C_v1_xxxxx configurations

2) CF_EWL_Runtime

3) CF_EWL_C++

4) CF_EWL_C

5) Cleaned and built my project

View solution in original post

2 Replies
256 Views
trytohelp
NXP Employee
NXP Employee

Hi Christian,

If Matthew comments don't help you, let me know.

Be aware the MCU V10.5 has been released in September.

Regards

Pascal

0 Kudos
257 Views
mwais
Contributor II

Take a look at this thread: Odd / Irrelevant Linker Warnings in CW v10.4

I was able to import the coldfire_lib located at C:\Freescale\CW MCU v10.4\MCU\ColdFire_Support\ewl

locate coldfire_lib project to import into CW 10.4

pastedImage_1.png

Once imported, select Build configuration and  a large menu like the one below is displayed.  Select the appropriate build configuration and do a clean and build. See sequence below

pastedImage_2.png

I cleaned and rebuilt these configurations in this order:

1) ALL the EWL_C_v1_xxxxx configurations

2) CF_EWL_Runtime

3) CF_EWL_C++

4) CF_EWL_C

5) Cleaned and built my project