RTI not pulling HSC08 out of STOP3/running

cancel
Showing results for 
Search instead for 
Did you mean: 

RTI not pulling HSC08 out of STOP3/running

Jump to solution
4,163 Views
Contributor II
I am trying to wake-up the HSC08 GB60 processor from a STOP3.  I am using the RTI1_init bean and have told it to interrupt every 64ms using the internal oscilator and gave it the name of my ISR I call RTI1_OnInterrupt.  I set a breakpoint on the first intruction of my ISR and I never reach it.  I never get out of STOP3 mode either.  What is the trick to getting this to work?
 
Thanks,
Kevin
Labels (1)
Tags (1)
0 Kudos
1 Solution
20 Views
Contributor II
I was able to get the RTI working today. I found that CW 5 does mess up the ability to have the 1khz oscillator running to allow the RTI to work. To make it work, the debug cable has to be off and the processor must be reset. I have heard that CW 3 does not have this issue, but I can not confirm this.

View solution in original post

0 Kudos
5 Replies
21 Views
Contributor II
I was able to get the RTI working today. I found that CW 5 does mess up the ability to have the 1khz oscillator running to allow the RTI to work. To make it work, the debug cable has to be off and the processor must be reset. I have heard that CW 3 does not have this issue, but I can not confirm this.

View solution in original post

0 Kudos
20 Views
Contributor I
For very low power modes, the problem is that the internal clock draws upwards of 20uA.  It's too bad the RTI cannot continue to interrupt in very low power mode.
0 Kudos
20 Views
Senior Contributor II
Hi,Kevin:
Is the oscillator set to keep running in STOP3 mode and operating at the correct bandwidth? Here is a snippet from the data sheet:
When using the external oscillator in stop3 mode, it must be enabled in stop (OSCSTEN = 1) and configured for low bandwidth operation (RANGE = 0).

Message Edited by rocco on 03-22-200612:52 PM

0 Kudos
20 Views
Contributor II
I am only using internal oscillators. There is supposed to be a 1khz oscillator internal to the MCU that should allow the wakeup. Is that correct?

Thanks,
Kevin
0 Kudos
20 Views
Senior Contributor II
Oops, sorry Kevin, I misread your first post.

I looks to me (but don't trust that!) that you are doing it correctly. The internal clock should run once you are in STOP3 mode (it won't run in RUN mode). Are all of the interrupt enables enabled?

There are a number of things that could be wrong. I find it hard to debug when the CPU is stopped. I would test it piecemeal:
1) select the external clock and get it interrupting in RUN mode, then
2) switch to STOP3 mode, and get it running there, and finally
3) switch to the internal clock and get it running.
0 Kudos