PE "Range Check Error" after License change (CW HC9S12)

cancel
Showing results for 
Search instead for 
Did you mean: 

PE "Range Check Error" after License change (CW HC9S12)

2,579 Views
Soror
Contributor I
Hi,

I received a new license file. Since then I can't load the Processor Expert in my projects. I always receive a "Range check error". I tried to reinstall CW but the error still exists.

If I try to enable PE and close CW it crashes and I receive the attached error.
I am thankful for any help.

Regards,

Soror
Labels (1)
Tags (1)
0 Kudos
6 Replies

94 Views
ProcessorExpert
Senior Contributor III
Could you please specify which version and what kind of license do you use?
On which operating system?

best regards
Petr Hradsky
Processor Expert Support Team
UNIS
0 Kudos

93 Views
Soror
Contributor I
hi,

i use:
IDE Version: 5.7.0 Build 2211

Detailed version numbers of the whole IDE are attached at the first post.
I use an WinXP OS. The license is a demo-license which we got from freescale Germany.
We use the license on 3 computers (all XP) and only my one has this problem. The other 2 are working correctly.
I also got a new license file from the freescale-support, but the problem still exists.

Thanks for your help.

Regards,

Andreas

0 Kudos

94 Views
CompilerGuru
NXP Employee
NXP Employee
I wonder if the license actually works on that particular PC.
Flexlm does detect on some PC's that the time was set back, and on such PC's temporary licenses do not work anymore. Of course
that's no excuse for the observed behavior, I just wonder if it is this special behavior which breaks it on that PC.

Can you on that PC start CW, open a project, go into the Linker for HC12 settings, open the About box, press extended, wait :smileywink:, and then copy paste all the text output you get in there?
That should show if the license is basically working or not. Can you also check the line endings using on that license.dat?
I though there have been problems with non windows license endings in old versions.

Is there another dump file created before the one you attached? I saw such dump files in the past only as result of other crashes/dumps happened before.

Daniel
0 Kudos

94 Views
Soror
Contributor I
Hi,

I am sorry for not having responded to your answers. I wasn't in my office for a week.

Thanks a lot for your answers. But astonishingly I came back and opend exactly the same project with exactly the same license.dat/CW installation as before and now everything is fine !?!?!?

@Guru: Unfortunately I don't have any other dump file.

@Jedi: The 3 computers are very different configurations. WinXP & SP is identical but offices are 2003 and 2000. Also the hardware is different (Laptop P3/ Desktop P4 / Desktop P3).

Well, I can work again so I am happy. If anyone would like to have any further information I can post it here.

Thanks a lot.

Regards,

Soror

0 Kudos

94 Views
J2MEJediMaster
Specialist I
Is there anything different between the system that doesn't work and the ones that do? Service packs installed? Microsoft Office installed? Amount of memory?

---Tom


Message Edited by J2MEJediMaster on 2007-08-15 11:42 AM
0 Kudos

94 Views
Steve
NXP Employee
NXP Employee
You may be more successful asking this question in the CodeWarrior 8/16bit forum since this seems to be a setup/license problem rather than an MCU problem.
0 Kudos