CW10.2(Eclipse) S08DZ - No chance to invoke burner via automatically generated makefile

cancel
Showing results for 
Search instead for 
Did you mean: 

CW10.2(Eclipse) S08DZ - No chance to invoke burner via automatically generated makefile

Jump to solution
353 Views
Contributor I

Hi all, 

I am working on workspace with two projects: PrA and PrB, where PrB is a copy of PrA with different name.

PrA generates for me perfect HEX file, PrB doesn't (the same bbl files). 

 

I found that automatically generated makefile of PrB differs only in this part:

PrA (automatically generated makefile):

# Add inputs and outputs from these tool invocations to the build variablesEXECUTABLES += \Project.abs \EXECUTABLES_QUOTED += \"Project.abs" \EXECUTABLES_OS_FORMAT += \Project.abs \BURNER_OUTPUT_OUTPUTS += \Project.abs.s19 \BURNER_OUTPUT_OUTPUTS_QUOTED += \"Project.abs.s19" \BURNER_OUTPUT_OUTPUTS_OS_FORMAT += \Project.abs.s19 \

 

 PrB (automatically generated makefile):

# Add inputs and outputs from these tool invocations to the build variables EXECUTABLES += \EXECUTABLES_QUOTED += \EXECUTABLES_OS_FORMAT += \BURNER_OUTPUT_OUTPUTS += \BURNER_OUTPUT_OUTPUTS_QUOTED += \BURNER_OUTPUT_OUTPUTS_OS_FORMAT += \

 

When I put missing strings into obove lines, and disable "auto makefile generation" option, it builds requested output file with success.  

 

I cannot  find source in project configuration connected with this issue. Maybe I miss something in burner or linker options ?

Anyone had such problem ?

 

regards!

Paweł

Labels (1)
Tags (1)
0 Kudos
1 Solution
25 Views
Specialist I

For project B has you specified "Project.abs" as your artifact file (that is, output file)?

To specifiy the output name choose:

 

Project > Properties > C/C++ Build > Settings > Build Artifact tab

 

---Tom

 

 

View solution in original post

0 Kudos
2 Replies
26 Views
Specialist I

For project B has you specified "Project.abs" as your artifact file (that is, output file)?

To specifiy the output name choose:

 

Project > Properties > C/C++ Build > Settings > Build Artifact tab

 

---Tom

 

 

View solution in original post

0 Kudos
25 Views
Contributor I

Thank you for the answer Tom,

 

So, there I have the following:

 

Artifact Type: empty field

Artifact name: Project

Artifact extension: abs

Output prefix: empty field

 

IMO it looks normal - exacly like in the PrA.

 

regards, Paweł

0 Kudos