ecd.exe does not yield same results when running several times.

cancel
Showing results for 
Search instead for 
Did you mean: 

ecd.exe does not yield same results when running several times.

385 Views
Contributor I

We are using Jenkins to automate a lot of things in our project, one of those things is the build of the elf files.

we are using ecd.exe to do so, but after a  lot of trying and failing, I can only come to the conclusion there is something "hidden from our eyes".

 

we are running ecd.exe with the same parameters, time after time, on different computers, and without changing anything (no new code, no configuration change) sometime the process is successful and sometime it fails.

 

does anyone have any experience with this tool?

we are using Codewarrior 10.4 for PA.

 

your input will be greatly appreciated.

Labels (1)
0 Kudos
3 Replies

3 Views
NXP Employee
NXP Employee

Hi Amit,

I've never used Jenkins under Eclipse but created a doc explaining how to use Jenkins with Classic Version.

    Classic - How to use dashboard (Jenkins) to build a CodeWarrior project?

Under Eclipse, it seems there is a plugin too:

    Use Jenkins - Jenkins - Jenkins Wiki

Under Tool Integration Eclipse plugin

    Google Code Archive - Long-term storage for Google Code Project Hosting.


Have a great day,
Pascal
NXP Technical Support

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

3 Views
Contributor I

Hi,

thanks for the quick answer :smileyhappy:

unfortunately, it is not exactly what I was aiming for.

we are already using jenkins as described, and that part is working perfectly (the job is well configured, and runs as expected).

we are using a batch file, which is starting the tool provided with code warrior. the tool is "ecd.exe".

like I mentioned before, the problem lies within that tool, which appears to have inconsistent results. I was talking to other guys in the company, and it seems like this problem is not unique to my case...

am I missing something? should I configure the file in a specific way to make it work properly?

running manually always works fine, but running from the jenkins job yields un-deterministic results...

0 Kudos

3 Views
NXP Employee
NXP Employee

Dear Amit,

Sorry for delay.

So running the project outside jenkins it's working fine.

Problem occurs "sometimes" when ecd.exe is called through jenkins.

    Am I right ?

CW for PA V10.5 has been released recently.

Did you tried with this new version ?

To handle the question we need to reproduce the behavior.

To do that I need exactly to have the same configuration you're using.

How are you using Jenkins ?

May be it could be better to continue to handle the problem via the Case.

To submit your case into the new system, please follow below steps:

   1) Go to http://www.nxp.com/support/sales-and-support:SUPPORTHOME.

   2) On the bottom of the page under Submit New Issues, click Hardware & Software.

   3) Register with your business email to access NXP technical online support.

   4) A verification email will be sent to your account. Click the link embedded in that email to verify your access.

   5) On the NXP online support page, select Contact Support from the top menu and click “submit a new case” to start the process.

Have a great day,
Pascal
NXP Technical Support

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos