I recently updated from CW 10.2 to 10.5. I now get unresolved inclusion warnings in my projects for all linked files. The builds run OK but I always have the warnings...is there an issue with this version.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

I recently updated from CW 10.2 to 10.5. I now get unresolved inclusion warnings in my projects for all linked files. The builds run OK but I always have the warnings...is there an issue with this version.

2,234 Views
flacca
Contributor II

I recently updated from CW 10.2 to 10.5. I now get unresolved inclusion warnings in my projects for all linked files. The builds run OK but I always have the warnings...is there an issue with this version.

Labels (1)
9 Replies

1,644 Views
sudhanshumehta
Contributor IV

thanks

worked for me as well

0 Kudos

1,644 Views
ZhangJennie
NXP TechSupport
NXP TechSupport

Please check whether the setting for include file's searching path is correct.

For example, if you use kinetis,

1)      Put your mouse on the source file folder in Project Panel, then right click mouse to select 'Properties'

2)      Go to C/C++ Build-> Settings, under <Tool Settings> tab, go to ARM compiler -> Input, whether the path for the specific file is listed here? If not, please add it.

3)      Go to C/C++ General-> Paths and Symbols, under <Includes> tab, go to C source File, whether the path for the specific file is listed here? If not, please add it.

if the problem persists, please upload your project here. we can check.

0 Kudos

1,644 Views
joelesco
Contributor III

Hi Zhang Jennie !

I have exactly the same problem ! When I include path I obtain inresolved inclusion but my project works, but a lot of include still underlined !
I saw in the paths and Symbols something strange. There is two assembly, is it normal ? More over the 3 last folder are warning? are they necesary ?   :

Sans titre.jpg

Thanks a lot !

0 Kudos

1,644 Views
philmalessa
Contributor I

Hi Jérémie Lescaudron,

I had the same problem a few days ago.

I kind of found a solution for me.

In my case it was a missing checkbox in "Allow heuristic resolution of includes".

You can find it in the workspace settings:

     - Open the Project Properties

     - Click on C/C++ General -->Indexer

     - Don´t select "Enable project specific settings", but click on "Configure Workspace Settings"

indexer.png

This is my selection on this page.

Then rebuild your Index and it should be fine!

EDIT: I have two "Assembly" includes, too.

Greetings,

Phil Malessa

1,644 Views
panpwr
Contributor IV

Wow, that even solved my issue on CW 10.6.4!! :smileyhappy:

Thanks!

0 Kudos

1,644 Views
joelesco
Contributor III

Hi Phil,

I 've tried  your solution and now it works ! I think it's the "index unused headers" tick wich resolve the problem !

Thanks a lot for your help !

0 Kudos

1,644 Views
BlackNight
NXP Employee
NXP Employee

Could you post a screenshot or more information?

What compiler are you using?

If you get an unresolved inclusion warning, that typically means that either your compiler or Eclipse is not able to find the header file.

Can you check your compiler settings if that path is present?

What could be an issue is as well if for whatever reason you are using an environment variable for your inclusions which somehow does not get resolved?

0 Kudos

1,644 Views
gaetanoanania
Contributor III

Hi Erich,

I have a similar problem. When I include a header file into the CW 10.5 and into Properties/setting Path the folder the program builds but write unresolved inclusion. I use Arm Compiler of freescale.

Thank you

0 Kudos

1,644 Views
trytohelp
NXP Employee
NXP Employee

Hi Geatano,

Sorry for the delay.

when you add a header file in the project, is it listed in Project-Headers folder too ?

Regards

Pascal

0 Kudos