Does anybody know why my Ctl-C, Ctl-V, Delete key (and possibly some other editting keystrokes have stopped working in CW MCU 10.5?)

cancel
Showing results for 
Search instead for 
Did you mean: 

Does anybody know why my Ctl-C, Ctl-V, Delete key (and possibly some other editting keystrokes have stopped working in CW MCU 10.5?)

Jump to solution
1,288 Views
Symbolic
Contributor III

I just did a software update of my CW MCU 10.5 this morning.

Sometime this afternoon, a number of heavily used editing keystrokes became non-functional.

Included are:  Ctl-C, Ctl-V, and Delete

Ctl-Z and Ctl-Y seem to be still functional, as are the "right-click" and select commands for copy and paste.

(In other words, the underlying cut/paste seems to  be working, but the keystrokes are not triggering the actions.)

I am NOT using any custom editor.

Other apps appear to work fine....  including this web-page    ("e....  including this web-page" an example done intentionally)

I have unplugged and re-plugged the USB keyboard.

I have shut down the machine, installed all Windows updates, and re-booted.

The problem is persisting!

This is HEAVILY counter-productive and ANNOYING.

This is suspiciously like something in the software update has clobbered something (but not, of course, conclusive)

 

H      H      EEEEEE          L                  PPPPPP

H      H      E                       L                  P             P

HHHH      EEEE               L                  PPPPPP

H      H      E                       L                  P

H      H      E                       L                  P

H      H      EEEEEE         LLLLLL       P

Labels (1)
0 Kudos
1 Solution
108 Views
Symbolic
Contributor III

For further information and updates, please go to the post:

Most keybindings and shortcuts stopped working after today's update to 10.5

where I will be doing any further postings

(there is a temporary workaround in there that appears to be a short term solution)

View solution in original post

0 Kudos
6 Replies
109 Views
Symbolic
Contributor III

For further information and updates, please go to the post:

Most keybindings and shortcuts stopped working after today's update to 10.5

where I will be doing any further postings

(there is a temporary workaround in there that appears to be a short term solution)

View solution in original post

0 Kudos
108 Views
marceli2014
Contributor I

after use Ctrl-X it restores CTrl-V and Ctlr-C and also DEL key. Maybe default keys are set to different on start up. Then in Window/Preferences/General/Keys use Restored Command for above keys and Apply. It should help.

0 Kudos
108 Views
martinphilipp
Contributor I

Same here.

My temporary Solution for copy, cut & paste:

Go to Window->Preferences->General->Keys.

Search for cut, select the one with Ctrl + x binding and click on unbind command.

Same for copy and paste.

But my delete key is still not working..

0 Kudos
108 Views
robertyork
Contributor II

I have exactly the same problem. Need a solution for this. Sometimes restarting Codewarrior fixes it, sometimes it doesn't.

0 Kudos
108 Views
jeremiahg
Contributor III

I also have this same exact problem on two PC's. Both of my PC's are Windows 8.1 Pro 64-bit. I really thought that my keyboard died at first. It is very annoying.

0 Kudos
108 Views
BlackNight
NXP Employee
NXP Employee

I really don't know what this is, as I had that with stock Eclipse (e.g. Kepler) too. So to me this is not a CodeWarrior problem: it seems to be a general Eclipse problem. It believe it could be because of some recent Microsoft Service packs (I'm using Windows 7 64bit), and I noticed the problem appeard after IT has updated my machine. It is just a guess, and I'm unable to confirm it.

I noticed that the shortcuts go away, and after a while they are back again.

0 Kudos