How to install iMX21_LINUX_BSP_GNU_ToolChn.zip?

cancel
Showing results for 
Search instead for 
Did you mean: 

How to install iMX21_LINUX_BSP_GNU_ToolChn.zip?

1,421 Views
AshishVyas
Contributor I
Hi All,

While downloading the linux image to imx21ADS board, I get the following error:
home/imx21ADS/ltib-imx21ads-20070609/bin/imx21_download: /lib/tls/libc.so.6: version 'GLIBC_2.4' not found (required by /home/imx21ADS/ltib-imx21ads-20070609/bin/imx21_download).

So,
I downloaded "iMX21_LINUX_BSP_GNU_ToolChn.zip" from the site (size: 434,078K). It has glibc2.1.3.tar.gz and an install script inst_glibc2.1.3
However the script returns the error when I run it:
bad interpreter: No such file or directory.
Also, there is no documentation on how to use the toolchain zip file.

Can some one guide me how to install this toolchain (
iMX21_LINUX_BSP_GNU_ToolChn.zip)?

Thanks in advance
Ashish


Message Edited by Ashish Vyas on 2008-03-26 03:49 AM
Labels (1)
0 Kudos
1 Reply

102 Views
fsl_linux_spt
Contributor III
Hi Ahish,
 
You do not need to use the toolchain.gz.  I am not even sure what that is, or what it is for.
The LTIB bsp you are using has a much newer toolchain/glibc than the zipped file you are asking about.
 
It looks like the issue you are running into is with the glibc version on your host PC.  The mx21_download utility cannot find a glibc that has the version support it is looking for. 
 
What Linux distribution and version are you running the MX21ADS bsp on?
 
 
Coray
0 Kudos